Ticket #143 (closed Bug: fixed)

Opened 8 years ago

Last modified 7 years ago

Browser locks with <!--{PS..x}--> in the contents

Reported by: anonymous Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version: FCKeditor 2.4
Keywords: SF Confirmed Cc:

Description

We found a little bug. If you paste the following code in your editor (v 2.4 or older) and then switch 2 oder 3 time between source code and normal view the browser (IE 6 and 7 and Firefox 1, 1.5 and 2) hang up.

This is the code:

<h1>Test</h1>
<h4>test</h4>
<!--{PS..0}--><!--{PS..2}-->
<!--{PS..3}-->
test

Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1648545&group_id=75348&atid=543653

Change History

comment:1 Changed 8 years ago by fredck

  • Reporter changed from fredck to anonymous

comment:2 Changed 8 years ago by fredck

  • Keywords Confirmed added

We are aware about this issue. It happens because of the Protected Source feature, which enters in a loop in that case.

In any case, one would only have <!--{PS..x}--> comments in the HTML if accessing the editor area innerHTML directly, instead of using EditorInstance.GetXHTML(). The innerHTML method is not recommended because the editor must make some changes in the HTML before retrieving it (like the Protected Source processing, for example).

In any case, we'll be working to fix it.

comment:3 Changed 8 years ago by fredck

  • Milestone set to FCKeditor 2.5

comment:4 Changed 7 years ago by martinkou

  • Status changed from new to closed
  • Resolution set to fixed

Fixed with [483].

Click here for more info about our SVN system.

comment:5 Changed 7 years ago by fredck

I liked the unique label idea. I've simplified the code with [485].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy