Opened 11 months ago

Closed 9 months ago

#14449 closed New Feature (fixed)

New Balloon Panel plugin

Reported by: Anna Owned by: Tade0
Priority: Normal Milestone: CKEditor 4.6.0
Component: General Version: 4.5.7
Keywords: Cc:

Description (last modified by m.lewandowski)

The Balloon Panel plugin used by Accessibility Checker needs to be added to CKEditor core repository. It will be available as an official optional plugin, under the same licenses as CKEditor.

Things to check:

  1. Code quality.
  2. Test coverage.
  3. License and copyright headers.
  4. API docs.
  5. Language strings (if any).
  6. Manual test.
  7. Move active balloonpanel issues to Trac.

Change History (17)

comment:1 Changed 11 months ago by Anna

  • Status changed from new to confirmed

comment:2 Changed 11 months ago by Anna

  • Description modified (diff)

comment:3 Changed 11 months ago by Anna

  • Description modified (diff)

License, copyright headers, API docs corrected in GH.

comment:4 Changed 11 months ago by m.lewandowski

We need couple more things: manual test, SDK sample and we need to remember to move open balloonpanel issues to Trac.

Last edited 11 months ago by m.lewandowski (previous) (diff)

comment:5 Changed 11 months ago by m.lewandowski

  • Description modified (diff)

comment:6 Changed 11 months ago by Tade0

  • Owner set to Tade0
  • Status changed from confirmed to assigned

comment:7 Changed 11 months ago by m.lewandowski

  • Description modified (diff)

comment:8 Changed 11 months ago by Anna

Re SDK sample - we agreed it would be a nice idea, but it's not a priority and we need to have a really interesting use case to show how Balloon Panel can be used without AC and still impress the developers.

comment:9 Changed 11 months ago by m.lewandowski

SDK sample extracted to issue #14520.

comment:10 Changed 11 months ago by Tade0

  • Status changed from assigned to review

Done so far:

  1. Plugin added to CKE repo.
  2. Corrected some minor style errors.
  3. Created manual test.

comment:11 Changed 10 months ago by m.lewandowski

  • Status changed from review to review_failed

Pushed couple of minor changes.

  • We need also to provide a skin for kama.
  • In dev sample close button does not work, let's fix it. Is it the issue of sample, or the balloon plugin itself? I believe it's the later.
  • We need to create a general manual test for balloonpanel. I recall there was an issue with body margin, I think it could be easily solved by overriding bender styles in manual test HTML file with a stylesheet element.
Last edited 10 months ago by m.lewandowski (previous) (diff)

comment:12 Changed 10 months ago by Tade0

  • Status changed from review_failed to review

Added a manual test that should be flexible enough to test most cases.

Changes pushed to branch:t/14449.

comment:13 Changed 10 months ago by m.lewandowski

  • Status changed from review to review_failed
  1. Restructured test steps in panel.md test.
  2. panel.md:

Manual test: http://tests.ckeditor.dev:1030/tests/plugins/balloonpanel/manual/panel

The panel should move when the editor is scrolled so that it always points at "Test L".

Fails.

The panel should stay (when it's possible) within the viewport and the editor area.

Fails. There's actually no convienient way to test it, the content is not as high that you could make "Test L" go out of the border of ther editor. I've tested it simply by setting editor height to 300.

  1. balloonpanel.md let's reduce plugin amount
  2. balloonpanel.md - Please simplify the process, just show the balloonpanel when tester clicks any <strong>. This TC must be as simple as possible.
  3. We no longer need dev sample, since we have manual test.
Last edited 10 months ago by m.lewandowski (previous) (diff)

comment:14 Changed 10 months ago by Tade0

  • Status changed from review_failed to review

Simplified manual tests as requested in comment:13. Deleted dev sample.

Note: the features described in panel.md don't seem to be implemented at the moment.

comment:15 Changed 9 months ago by m.lewandowski

  • Status changed from review to review_failed

There's still no skin for kama.

Please provide fixes asap, let me know if you need any information.

comment:16 Changed 9 months ago by Tade0

  • Status changed from review_failed to review

Fixed.

Changes pushed to branch:t/14449.

comment:17 Changed 9 months ago by m.lewandowski

  • Description modified (diff)
  • Resolution set to fixed
  • Status changed from review to closed

Fixed with git:8ab1a8202c (merged to major).

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy