Ticket #1451 (closed Bug: fixed)

Opened 7 years ago

Last modified 4 years ago

Safari (Win) : Anchors are not created correctly

Reported by: bhakti Owned by:
Priority: Normal Milestone: Safari Compatibility
Component: General Version: FCKeditor 2.5 Beta
Keywords: Safari Win Confirmed Cc:

Description

Anchor is not getting displayed. Click on the anchor icon and give the details, hit the Ok button. Nothing comes up on the Editor.

Safari version : Version 3.0.3(522.12.1) OS : Test is running on the Win XP server

Change History

comment:1 follow-up: ↓ 4 Changed 7 years ago by fredck

  • Keywords Safari Win Confirmed added
  • Summary changed from Problems in Anchor to Safari (Win) : Anchors are not created correctly
  • Milestone changed from FCKeditor 3.0 to Safari Compatibility

It works for me with the same browser, over Mac.

On Windows, I'm having something strange, but not as you've describe. I have the anchor created and visible, but it's contents are not empty, as expected. I'm having an output like the following:

<a name="Test">javascript:void(0);/*1193152122906*/</a>

So, I confirm we have a buggy behavior, even if different of what you have described.

comment:2 follow-up: ↓ 3 Changed 7 years ago by sojweb

I think I can clarify the original bug: If you create an empty anchor at the beginning of a paragraph, the anchor image doesn't show up in Safari. For instance, the following code should exhibit the behavior:

<p><a name="anchorName"></a>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>

As should this:

<div><a name="anchorName"></a>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</div>

But this shouldn't:

<p>X<a name="anchorName"></a>This is some <strong>sample text</strong>. You are using <a href="http://www.fckeditor.net/">FCKeditor</a>.</p>

On Windows I get the same behavior, not the weird output you were getting, but that may be because I have 3.0.3 (522.15.5). My Mac version is 3.0.3 (522.12.1).

comment:3 in reply to: ↑ 2 Changed 7 years ago by alfonsoml

Replying to sojweb:

I think I can clarify the original bug: If you create an empty anchor at the beginning of a paragraph, the anchor image doesn't show up in Safari. For instance, the following code should exhibit the behavior:

These are the corresponding webkit bugs (the problem also exists in a static page): http://bugs.webkit.org/show_bug.cgi?id=13237 http://bugs.webkit.org/show_bug.cgi?id=13995

comment:4 in reply to: ↑ 1 Changed 7 years ago by alfonsoml

Replying to fredck:

It works for me with the same browser, over Mac.

On Windows, I'm having something strange, but not as you've describe. I have the anchor created and visible, but it's contents are not empty, as expected. I'm having an output like the following:

<a name="Test">javascript:void(0);/*1193152122906*/</a>

So, I confirm we have a buggy behavior, even if different of what you have described.

It seems that Safari is creating automatically the content for a link where there is no selected text, and due to the way that links are created in FCKeditor it shows the temporary url. The solution could be to check if there is no selection before creating the link, and then after the link is created (still inside FCK.CreateLink), reset the content if it was empty.

comment:5 Changed 7 years ago by fredck

Fixed comment:2 with [1096].

comment:6 Changed 7 years ago by fredck

Correcting... comment:1 has been fixed with [1096].

comment:7 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Resolution set to fixed

For comment:2, the WebKit ticket related to that bug has already been closed, and I can confirm it is working with the latest WebKit nightly. So, this ticket can be closed, as the solution is is supposed to come with the next Safari update.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy