Opened 8 months ago

Closed 8 days ago

Last modified 8 days ago

#14742 closed Bug (worksforme)

[Edge] Editor scrolls down when trying to edit inline widget.

Reported by: Tade0 Owned by: Tade0
Priority: Normal Milestone:
Component: General Version: 4.5.11
Keywords: Cc:

Description

Steps to reproduce

  1. Open http://tests.ckeditor.dev:1030/tests/plugins/widget/manual/inline in Edge
  2. Double-click on a placeholder widget(e.g. Dwight Hooker?) to edit it.

Expected result

The edit dialog appears.

Actual result

The edit dialog does not appear, the editor is scrolled down.

Other details (browser, OS, CKEditor version, installed plugins)

Browser: Edge.

Change History (15)

comment:1 Changed 8 months ago by j.swiderski

  • Keywords edge inline widget scroll dialog removed
  • Status changed from new to confirmed

There is similar ticket #13577

comment:2 Changed 8 months ago by Tade0

  • Owner set to Tade0
  • Status changed from confirmed to assigned

comment:3 Changed 8 months ago by Tade0

Findings so far: To reproduce the error cut & paste internally the image widget that's in the editor.

After this clicking on any widget will scroll down, but not completely, because just after pasting the string "Lena Söderberg image widget" was appended to the end of the editor and that's where the editor scrolls.

comment:4 Changed 8 months ago by Tade0

Apparently this is one of those situations, where Edge behaves differently than IE, but since CKEDITOR.env.ie is true, the code is executed through a path, that causes errors.

Changing how the hidden selection container is generated partially mitigated the problem (see branch:t/14742), but this is not enough to solve this bug.

comment:5 Changed 7 months ago by m.lewandowski

  • Milestone changed from CKEditor 4.5.11 to CKEditor 4.6.1

comment:6 Changed 4 months ago by m.lewandowski

Moving to 4.6.2 minor release, as 4.6.1 is mostly about polishing 4.6.0.

comment:7 Changed 4 months ago by m.lewandowski

  • Milestone changed from CKEditor 4.6.1 to CKEditor 4.6.2

comment:8 Changed 3 months ago by m.lewandowski

  • Milestone changed from CKEditor 4.6.2 to CKEditor 4.7.0

comment:9 Changed 6 weeks ago by Tade0

There seems to be some kind of race condition enabling this bug, because adding the debugger statement in each paste listener and observing the state of the editor was enough to make the bug not appear.

comment:10 Changed 5 weeks ago by Tade0

The problem is in the way the paste event is handled in the widget plugin.

The data is modified using a regex that in Edge results in malformed content.

comment:11 Changed 5 weeks ago by Tade0

Previous comment is wrong.

The real problem happens in this method: http://docs.ckeditor.com/#!/api/CKEDITOR.editable-method-insertHtml

Somehow what eventually gets selected is not the content in the supplied range.

comment:12 Changed 5 weeks ago by Tade0

Some conclusions:

  • The text that appears at the end of the editable after pasting is the ARIA label of the widget. It's not the hidden selection container - just its content.
  • Putting a breakpoint anywhere will make this bug not appear - either there's some asynchronous even going on, or it's a browser bug.

Added a minimal manual test for this case.

comment:13 Changed 2 weeks ago by Tade0

  • Status changed from assigned to review

Rebased with current major and it seems the problem... went away?

comment:14 Changed 8 days ago by t.jakut

  • Resolution set to worksforme
  • Status changed from review to closed

It seems that bug is really gone – I can't reproduce it even on 4.5.11 version. Maybe some update for Edge fixed it?

comment:15 Changed 8 days ago by m.lewandowski

  • Milestone CKEditor 4.7.0 deleted

Well done!!! :P

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy