Opened 10 months ago

Closed 12 days ago

Last modified 12 days ago

#14762 closed Bug (fixed)

Tableresize plugin:"Error: Unable to get property 'cells' of undefined or null reference" when the table has no row/cells

Reported by: mlaberge Owned by: beata_delura
Priority: Normal Milestone: CKEditor 4.7.0
Component: Core : Tables Version: 4.0
Keywords: Cc:

Description

Steps to reproduce

  1. Table Resizer plugin installed.
  2. In the editor, go to source mode, then type :

<table border="1" cellspacing="2" style="width:400px">

<tbody> </tbody>

</table>

  1. Close the source view
  2. Drag the mouse over the empty table

Expected result

Nothing should happen, table is empty

Actual result

Error: Unable to get property 'cells' of undefined or null reference

Other details (browser, OS, CKEditor version, installed plugins)

Browser is IE 11, CK Editor 4.5.10, Table Resizer plugin installed.

Change History (11)

comment:1 Changed 9 months ago by j.swiderski

  • Status changed from new to confirmed
  • Summary changed from Table resizer : "Error: Unable to get property 'cells' of undefined or null reference" when the table has no row/cells to Tableresize plugin:"Error: Unable to get property 'cells' of undefined or null reference" when the table has no row/cells
  • Version changed from 4.5.10 (GitHub - master) to 4.0

Such table structure seems to be valid - https://html.spec.whatwg.org/multipage/tables.html#the-tbody-element.

Problem can be reproduced from CKEditor 4.0 in all browsers. just hover over empty table.

comment:2 Changed 3 weeks ago by beata_delura

  • Owner set to beata_delura
  • Status changed from confirmed to assigned

comment:3 Changed 3 weeks ago by beata_delura

  • Status changed from assigned to review

comment:4 Changed 2 weeks ago by k.krzton

  • Status changed from review to review_failed

comment:5 Changed 2 weeks ago by beata_delura

  • Status changed from review_failed to assigned

comment:6 Changed 2 weeks ago by beata_delura

  • Status changed from assigned to review

comment:7 Changed 13 days ago by k.krzton

  • Status changed from review to review_failed

comment:8 Changed 13 days ago by beata_delura

  • Status changed from review_failed to assigned

comment:9 Changed 13 days ago by beata_delura

  • Status changed from assigned to review

comment:10 Changed 12 days ago by k.krzton

  • Resolution set to fixed
  • Status changed from review to closed

Fixed with 9f08a20.

comment:11 Changed 12 days ago by k.krzton

  • Milestone set to CKEditor 4.7.0
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy