Opened 10 months ago

Closed 8 months ago

Last modified 8 months ago

#14867 closed Bug (fixed)

When pasting content from MS Word, text getting stripped. Only occurs in FireFox

Reported by: kevinji Owned by: m.lewandowski
Priority: Normal Milestone: CKEditor 4.6.0
Component: Plugin : Paste from Word Version: 4.5.0
Keywords: FireFox Cc:

Description

Steps to reproduce

  1. Open the attached MS Word document
  2. Copy and paste the content to the online CKEditor demo (http://ckeditor.com/demo#standard)
  3. You will notice some text got stripped in the first bullet

Expected result

Content pasted fully

Actual result

Some text stripped

Other details (browser, OS, CKEditor version, installed plugins)

This only happens in Firefox. Version of Firefox used for testing is 48.0.2. Pasting from MS Word works in Chrome.

After some investigations, it appears the pastefromword plug-in is stripping the text. When the plug-in's disabled, this problem goes away. We need the plug-in so disabling the plug-in permanently is not an option.

Attachments (1)

examples.docx (15.0 KB) - added by kevinji 10 months ago.

Download all attachments as: .zip

Change History (6)

Changed 10 months ago by kevinji

comment:1 Changed 9 months ago by j.swiderski

  • Component changed from Core : Pasting to Plugin : Paste from Word
  • Keywords MS Word paste removed
  • Status changed from new to confirmed
  • Version changed from 4.5.11 to 4.5.0

Problem can be reproduced in Firefox only. Starting from version 4.5.0 there is an error displayed that data could not be cleaned due to an error. Starting from version 4.5.2 part of text is missing.

comment:2 Changed 8 months ago by m.lewandowski

Just for the record the removed text is "`longer miss school because they are sick.".

comment:3 Changed 8 months ago by m.lewandowski

  • Milestone set to CKEditor 4.6.0

This issue will get resolved with #9991.

comment:4 Changed 8 months ago by m.lewandowski

  • Owner set to m.lewandowski
  • Status changed from confirmed to assigned

comment:5 Changed 8 months ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from assigned to closed

It's fixed by #9991.

Fixed with git:f2af0353f8fb20231c7ca6de080c6cad273195eb merged to major.

Last edited 8 months ago by m.lewandowski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy