Opened 9 months ago

Closed 5 months ago

#14903 closed Bug (duplicate)

Autolink regexp is not accurate

Reported by: m.lewandowski Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

As our user points out on a GitHub.

Steps to reproduce

  1. Open editor with autolink plugin.
  2. Paste following link https://prism-break.org/en/projects/cryptpad/

Expected result

Pasted link gets converted into an a element.

Actual result

Link gets pasted as plain text.

In search of the perfect URL validation regex might help with finding a good regexp.

Change History (4)

comment:1 Changed 9 months ago by m.lewandowski

  • Status changed from new to confirmed

comment:2 Changed 9 months ago by a.nowodzinski

cc

comment:3 Changed 7 months ago by j.swiderski

Other issues for autolink plugin: #13569, #14903, #16685.

Last edited 5 months ago by j.swiderski (previous) (diff)

comment:4 Changed 5 months ago by j.swiderski

  • Resolution set to duplicate
  • Status changed from confirmed to closed

It has turned out this is a duplicate of #14769.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy