Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1521 closed Bug (fixed)

"Replace" function doesn't work properly

Reported by: PavelZ Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.5
Component: General Version: FCKeditor 2.5 Beta
Keywords: Confirmed Cc:

Description

Steps to reproduce:

in FCK do:

aaaaaaaa
<Enter>
aaaaaaaa

Do replacement: replace all "aa" with "xx" In FF the result is:

xxaaaaaa
aaaaaaaa

and JavaScript error occures.

In IE the result is:

xx
xx

but with no JavaScript error

Both are bad.


Tested in FCK demo (ver. 2.5 Beta Build 16848)

Change History (5)

comment:1 Changed 9 years ago by fredck

  • Keywords Replace removed
  • Priority changed from High to Normal

comment:2 Changed 9 years ago by alfonsoml

  • Keywords Confirmed added

The bug is present in all the browsers, it seems that this will need a good review

comment:3 Changed 9 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

comment:4 Changed 9 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [1078], [1079] and [1080].

Click here for more info about our SVN system.

comment:5 Changed 9 years ago by martinkou

By the way, the bug was caused by the changes in [969]. A regression test might be needed to be written for this in the FCKTest tree to make sure it works in the future in case there are more changes to the selection related code.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy