Ticket #1535 (closed Bug: invalid)

Opened 6 years ago

Last modified 6 years ago

CP1252 encoding issues

Reported by: ob197 Owned by: martinkou
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4.3
Keywords: Pending Cc:

Description (last modified by martinkou) (diff)

The commonly used Windows Codepage 1252 has two characters which are not covered by FCKEditor's HTML entities:

Ž Ž U+017D alt+0142
ž ž U+017E alt+0158

If you type these chars, FCKEditor will not turn them into entities. If you inititalize FCKEditor with a text that contains one of these entities, the entities will be re-encoded e.g. as Ž

Change History

comment:1 Changed 6 years ago by martinkou

  • Status changed from new to assigned
  • Owner set to martinkou
  • Description modified (diff)

Corrected wrong unicode point value in description.

comment:2 Changed 6 years ago by martinkou

  • Keywords Pending added

Did you define the initial value like this?

oFCKeditor.Value = "<p>Some symbols here:&yuml;&Yuml;&Zcaron;&zcaron;</p>";

If this is the case, then the &Zcaron and &zcaron entities wouldn't be converted to Ž and ž. According to my understanding, that is because they are not defined in the XHTML Latin-1 entity set, rather than being FCKeditor's fault. The W3C XHTML entity set have only defined latin character entities up to U+00FF.

Instead of using the invalid entity codes, using the plain characters works:

oFCKeditor.Value = "<p>Some symbols here:&yuml;&Yuml;Žž</p>";

If, on the other hand, FCKeditor converts the plain characters into &amp;Zcaron;, then there would be a bug. I wasn't able to reproduce that in my testing, however.

comment:3 Changed 6 years ago by martinkou

  • Status changed from assigned to closed
  • Resolution set to invalid

Ticket expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy