Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1559 closed Bug (fixed)

FF3: Color buttons are not closing previously opened panels

Reported by: fredck Owned by:
Priority: Normal Milestone: FCKeditor 2.5
Component: UI : Toolbar Version: SVN (FCKeditor) - Retired
Keywords: Firefox Cc:


With Firefox 3 Beta 1, when opening any combo in the toolbar, and immediately clicking on one of the color buttons, the previous combo panel will remain opened. It will be blocked there until clicking inside of it.

Change History (4)

comment:1 Changed 9 years ago by fredck

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [1111].

comment:2 Changed 9 years ago by martinkou

  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopened because the fix breaks #1583. The fix in this ticket produces a highly critical bug which affects all non-IE browsers.

The cause of this bug is that FF3 is calling invoking FCKPanel_Window_OnBlur() in a different way compared to FF2/Safari/Opera - it does not guarantee that a focused element would fire the onblur event whenever the user clicks on something else.

comment:3 Changed 9 years ago by martinkou

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed with [1129].

Click here for more info about our SVN system.

comment:4 Changed 9 years ago by fredck

My fault here.

Fortunately, a simpler solution can be found instead of [1129], which goes touching too much things for a pre-release change. I've reverted it with [1130], and proposed a new fix with [1131].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy