Ticket #1575 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Firefox: Empty paragraph added if an object tag occurs as first element in the body

Reported by: geirhelge Owned by: martinkou
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5 Beta
Keywords: Confirmed Firefox Cc:

Description (last modified by martinkou) (diff)

If <object> is the first tag in the source, firefox adds <p>&nbsp;</p> at the beginning of the document.

Firefox 2.0.9 / Ubuntu Gutsy and windows xp+vista Reproduced with the FCKeditor demo (2.5 Beta) and 2.4.3

How to reproduce:

  1. Go to source view
  2. Remove all content
  3. Insert: <object></object>
  4. Go to html view and then back to source view
  5. The html now looks like: <p>&nbsp;</p><object></object>

This do not happen in IE.

Change History

comment:1 Changed 6 years ago by martinkou

  • Owner set to martinkou
  • Keywords Confirmed Firefox added
  • Status changed from new to assigned
  • Description modified (diff)

Confirmed on Firefox, ok on IE, Safari and Opera.

comment:2 Changed 6 years ago by martinkou

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [1123].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy