Opened 4 months ago

Closed 10 days ago

#16809 closed Bug (fixed)

JS Error throwing in focusManager when editor instance in source mode loses focus.

Reported by: nwillettjeffries Owned by: beata_delura
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.7.1
Component: General Version: 4.6.2
Keywords: Chrome Cc: michael-wolfenden, bbalfour@…

Description (last modified by j.swiderski)

Steps to reproduce

  1. Visit http://nightly.ckeditor.com/17-01-19-07-07/standard/samples/
  2. Open browser dev tools.
  3. Switch Ckeditor instance on the page to Source mode.
  4. Click anywhere on the page outside of the editor instance.

Expected result

No js errors throw.

Actual result

Uncaught TypeError: Cannot read property '$' of undefined

at window.CKEDITOR.window.CKEDITOR.dom.CKEDITOR.focusManager.f (ckeditor.js:224) at window.CKEDITOR.window.CKEDITOR.dom.CKEDITOR.focusManager.<anonymous> (ckeditor.js:225) at ckeditor.js:26

Other details (browser, OS, CKEditor version, installed plugins)

MacOS Sierra, Chrome 55.0.2883.95. This is throwing in CKeditor 4.6.2, in addition to Nightly build.

Please also see comment:5 and comment:7 for other test cases.

Change History (13)

comment:1 Changed 4 months ago by j.swiderski

  • Keywords Chrome added
  • Status changed from new to confirmed
  • Version changed from 4.7.0 (GitHub - major) to 4.6.2

Problem can be reproduced in Chrome Win & Mac from CKEditor 4.6.2.

comment:2 Changed 4 months ago by j.swiderski

#16822 was marked as duplicate.

comment:3 Changed 4 months ago by m.lewandowski

  • Priority changed from Normal to Must have (possibly next milestone)

comment:4 Changed 4 months ago by michael-wolfenden

  • Cc michael-wolfenden added

comment:5 Changed 3 months ago by mdenburger

Another reproduction path is to use the 'divarea' plugin:

  1. checkout tag 4.6.2
  2. open plugins/divarea/samples/divarea.html
  3. click inside the editing area to focus it
  4. click the 'Source' button

This triggers the following JS error:

Uncaught TypeError: Cannot read property '$' of undefined
    at CKEDITOR.focusManager.doBlur (focusmanager.js:162)
    at CKEDITOR.focusManager.<anonymous> (focusmanager.js:180)
    at tools.js:578
Last edited 3 months ago by mdenburger (previous) (diff)

comment:6 Changed 3 months ago by bbalfour

  • Cc bbalfour@… added

comment:7 Changed 5 weeks ago by j.swiderski

Cannot read property 'contains' of null is thrown when tabbing through editors in sharedspace sample. Once you focus link and leave last editor, error gets thrown:

Message: Cannot read property 'contains' of null
URL: ckeditor-dev/plugins/indent/plugin.js
Line: 366

comment:8 Changed 5 weeks ago by j.swiderski

  • Description modified (diff)

#16873 was marked as duplicate.

comment:9 Changed 5 weeks ago by j.swiderski

Original TC and the one for divarea seem to have expired on master.

The last TC for shardspace however can still be reproduced. The same thing can be reproduced in inlineall sample - it is enough to tab through bunch of inline editors and you will get the "contains" error.

The inline tabbing can also be reproduced only in Chrome and only starting from CKEditor 4.6.2.

comment:10 Changed 5 weeks ago by m.lewandowski

  • Milestone set to CKEditor 4.7.1

comment:11 Changed 11 days ago by beata_delura

I can't reproduce that bug.

comment:12 Changed 11 days ago by beata_delura

  • Owner set to beata_delura
  • Status changed from confirmed to review

comment:13 Changed 10 days ago by j.swiderski

  • Resolution set to fixed
  • Status changed from review to closed

I could no longer reproduce the original TC. The TCs from comment:7 and comment:9 were extracted to #17028.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy