Opened 5 months ago

Closed 5 months ago

#16842 closed Bug (duplicate)

Autolink plugin does not recognize URLs with dashes

Reported by: rdschouw Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Paste http://www.the-art-of-web.com/php/parse-links/ into editor

Expected result

Link is recognized and turned hyperlink

Actual result

Link is not recognized

The problem is the regex on line 10 of autolink/plugin.js

It needs to change to: /(https?|ftp):\/\/(-\.)?([\s\/?\.#]+\.?)+(\/[\s]*)?[\s\.,]$/ig

Other details (browser, OS, CKEditor version, installed plugins)

Change History (1)

comment:1 Changed 5 months ago by j.swiderski

  • Keywords autolink removed
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 4.6.2 deleted

DUP of #14769.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy