Opened 2 months ago

Closed 2 weeks ago

Last modified 16 hours ago

#16857 closed Bug (fixed)

Ctrl + Shift + V blocked by copy formatting

Reported by: wwalc Owned by: k.krzton
Priority: Nice to have (we want to work on it) Milestone: CKEditor 4.7.0
Component: General Version: 4.6.0
Keywords: Cc:

Description (last modified by m.lewandowski)

Steps to reproduce

  1. Open "Document Editor" sample on ckeditor.com.
  2. Copy something, e.g. a part of a header.
  3. Press Ctrl + Shift + V to paste clipboard as plain text.

Expected result

Text is pasted.

Actual result

Text is not pasted.

Other details (browser, OS, CKEditor version, installed plugins)

We'd like implement this in a way that CTRL+SHIFT+V will paste formatting only if it has been activated with CTRL+SHIFT+C - so that the Copy Formatting icon is active, and the toolbar button shows "pressed" state.

If copy formatting is not active, then this hotkey will paste as plain text.

This will improve interoperability with apps like MS Word, which use exact same hotkey, while keeping the original paste as plain text hotkey for people that doesn't use copy formatting.

Issue caused by copy formatting using keyboard shortcut which is usually used to paste plain text browsers.

Change History (7)

comment:1 Changed 2 months ago by m.lewandowski

  • Milestone set to CKEditor 4.7.0
  • Priority changed from Normal to Nice to have (we want to work on it)
  • Status changed from new to confirmed

comment:2 Changed 7 weeks ago by Tade0

  • Owner set to Tade0
  • Status changed from confirmed to review

Solution was to return false after putting screen reader message that applying failed.

This way the keystroke handler knows not to prevent the default behaviour which is pasting plain text.

Changes pushed to branch:t/16857.

comment:3 Changed 6 weeks ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from review to closed

Fixed with git:caa3bcb3c2.

comment:4 Changed 6 weeks ago by m.lewandowski

  • Description modified (diff)

comment:5 Changed 2 weeks ago by m.lewandowski

  • Resolution fixed deleted
  • Status changed from closed to reopened

This fix no longer works after #16954, which surfaced underlying issue, that multiple command can not be hooked assigned to the same keystroke.

comment:6 Changed 2 weeks ago by k.krzton

  • Owner changed from Tade0 to k.krzton
  • Status changed from reopened to review

comment:7 Changed 2 weeks ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from review to closed

Rebased and merged (ff) using github. Diff available at https://github.com/ckeditor/ckeditor-dev/pull/341/files.

Last edited 16 hours ago by m.lewandowski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy