Opened 3 months ago

Closed 2 months ago

#16912 closed Bug (fixed)

Exception thrown when a single image is pasted using paste from Word

Reported by: t.jakut Owned by: k.krzton
Priority: Must have (possibly next milestone) Milestone: CKEditor 4.7.0
Component: General Version: 4.6.0
Keywords: Cc:

Description

Steps to reproduce

  1. Open http://sdk.ckeditor.com/samples/standardpreset.html
  2. Select and copy image.
  3. Click "Paste from Word" and follow instructions

Expected result

Image is pasted

Actual result

Error is thrown: Uncaught TypeError: Cannot read property 'style' of undefined

Change History (8)

comment:1 Changed 3 months ago by t.jakut

  • Status changed from new to confirmed

comment:2 Changed 3 months ago by m.lewandowski

  • Priority changed from Nice to have (we want to work on it) to Must have (possibly next milestone)

comment:3 Changed 3 months ago by k.krzton

  • Owner set to k.krzton
  • Status changed from confirmed to assigned

comment:4 Changed 3 months ago by k.krzton

I will recheck the issue since we removed paste dialogs in 4.7.0, it might get solved.

comment:5 Changed 3 months ago by k.krzton

The issue is still present on latest major.

comment:6 Changed 3 months ago by k.krzton

  • Status changed from assigned to review

comment:7 Changed 2 months ago by m.lewandowski

  • Status changed from review to review_failed

comment:8 Changed 2 months ago by m.lewandowski

  • Resolution set to fixed
  • Status changed from review_failed to closed
  • Summary changed from Paste from word incorrectly handles images to Exception thrown when a single image is pasted using paste from Word

Fixed with git:8f388d22d1.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy