Opened 2 months ago

Closed 5 days ago

#16928 closed Task (fixed)

Bleeding tests

Reported by: t.jakut Owned by: t.jakut
Priority: Normal Milestone: CKEditor 4.7.0
Component: General Version: 4.7.0 (GitHub - major)
Keywords: Cc:

Description

During running unit tests in sequence there are some bleeding, but still passing ones:

  • resourcemanager.js:211 Uncaught Error: [CKEDITOR.resourceManager.load] Resource name "default" was not found at "http://tests.ckeditor.dev:1030/apps/ckeditor/styles.js"
  • focusmanager.js:164 Uncaught TypeError: Cannot read property '$' of undefined
  • lang.js:54 Uncaught TypeError: Cannot set property 'dir' of undefined

These errors appear randomly, in different tests and don't show up if unit tests are run separately. Probably the issue is connected with the way in which Bender runs tests and causes that DOM is not always ready when the test runs.

Change History (6)

comment:1 Changed 2 months ago by t.jakut

  • Owner set to t.jakut
  • Status changed from new to assigned

comment:2 Changed 8 weeks ago by t.jakut

focusmanager.js:164 Uncaught TypeError: Cannot read property '$' of undefined is caused by #16935.

comment:3 Changed 8 weeks ago by t.jakut

  • Status changed from assigned to review

The other errors were easily resolved using some async magic (I've added wait in 3 places). It's also worth noting that these tests were bleeding only when run from Bender Dashboard, run directly behaved correcly.

Pushed branch:t/16928.

comment:4 Changed 5 days ago by k.krzton

  • Status changed from review to review_passed

Looks good.

comment:5 Changed 5 days ago by k.krzton

  • Milestone set to CKEditor 4.7.0

comment:6 Changed 5 days ago by k.krzton

  • Resolution set to fixed
  • Status changed from review_passed to closed

Fixed with cf4eaff.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy