Opened 3 months ago

Closed 2 months ago

Last modified 13 days ago

#16959 closed New Feature (invalid)

New support for Autocomplete feature with filter

Reported by: mubin327 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: sakshi.solanki@…, mubin.shaikh@…

Description

Same functionality as for the social media websites. @ key if preceded by space and followed by word character presents a typeahead list of pre-populated usernames or custom data that can be selected and inserted to text editor.

Change History (3)

comment:1 Changed 2 months ago by j.swiderski

  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.7.0 (GitHub - major) deleted

presents a typeahead list of pre-populated usernames or custom data

The problem is that the way of getting data is different across applications. Each application has its unique data structure may require different server-side code to get it. Because of that I don't think it is possible to create a general plugin.

I'm closing this issue for now. @mubin327 if you don't agree, please leave a comment.

comment:2 Changed 2 months ago by mubin327

Please check this demo.

http://navalgandhi1989.github.io/ckeditor-autocomplete-suggestions-plugin/

I want the autocomplete like this. That is i already implemented as per my requirment. But i am not able to filter out data as there are thousand+ data comming in suggestion box. So can in future (if currently ckeditor don't have any such plugin)ckeditor be able to do the same thing with some filter or text filter.

Last edited 2 months ago by mubin327 (previous) (diff)

comment:3 Changed 13 days ago by j.swiderski

But i am not able to filter out data as there are thousand+ data comming in suggestion box.

You are using context menu plugin and there is no other way to limit number of menu items but to create less of them. I think you would rather need to create some custom panel that gets updated whenever you type a letter.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy