Opened 3 weeks ago

Closed 2 weeks ago

#16997 closed Bug (invalid)

[Safari] SCAYT doesn't work in Private window

Reported by: karena Owned by:
Priority: Normal Milestone:
Component: UI : Spell Checker Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Open Safari Private Window
  2. Go to the standard sample http://sdk.ckeditor.com/samples/standardpreset.html
  3. Try to enable SCAYT

Expected result

SCAYT works.

Actual result

SCAYT doesn't work. There is an error in console:
QuotaExceededError (DOM Exception 22): The quota has been exceeded.

It seems it caused by Safari localStorage access restrictions in Private mode.

Other details (browser, OS, CKEditor version, installed plugins)

OSX, Safari 10.1

Change History (1)

comment:1 Changed 2 weeks ago by j.swiderski

  • Resolution set to invalid
  • Status changed from new to closed
  • Version 4.7.0 (GitHub - major) deleted

The error is being thrown in ckscayt.js on svc.webspellchecker.net.

SCAYT is CKEditor add-on maintained by another company. Normally we report such issues to SCAYT team - https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues but from what I can see it has already been reported - https://github.com/WebSpellChecker/ckeditor-plugin-scayt/issues/112. SCAYT doesn't work with private mode.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy