Opened 5 weeks ago

Closed 5 weeks ago

#17039 closed Bug (duplicate)

Switch from wysiwyg and click behind textarea inside table - Chrome hangs

Reported by: j.swiderski Owned by:
Priority: Normal Milestone:
Component: General Version: 4.0
Keywords: Chrome Cc:

Description (last modified by j.swiderski)

Steps to reproduce

  1. Open e.g. replacebycode.html sample and switch to source mode
  2. Paste below code
  3. Switch to wysiwyg
  4. Click behind textarea
<table border="1" cellpadding="0" cellspacing="0" style="width:500px">
 <tbody>
  <tr>
      <td><textarea></textarea></td>
  </tr>
 </tbody>
</table>

Expected result

Cursor is blinking behind the textarea.

Actual result

Browser tab hangs (it is especially painful in Windows because you can't even close the tab).

Other details (browser, OS, CKEditor version, installed plugins)

Problem can be reproduced only in Chrome (Windows and Mac) at least from CKEditor 4.0.

Change History (4)

comment:1 Changed 5 weeks ago by j.swiderski

  • Status changed from new to confirmed

comment:2 Changed 5 weeks ago by j.swiderski

  • Description modified (diff)

comment:3 Changed 5 weeks ago by j.swiderski

NOTE: It is possible to create table with textarea in wysiwyg mode and then clicking behind the textarea. It will work in that case but as soon as you switch to source, next wysiwyg and then to click behind the textarea, browser will hung.

comment:4 Changed 5 weeks ago by j.swiderski

  • Resolution set to duplicate
  • Status changed from confirmed to closed

It seems this issue is not related to textarea only but other form elements as well. I'm closing this one as a duplicate of #17003.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy