Ticket #1719 (closed Bug: fixed)

Opened 7 years ago

Last modified 6 years ago

Can't do unbold / unitalicize

Reported by: mayank1711 Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Confirmed Firefox Cc:

Description (last modified by fredck) (diff)

I just copy and paste the following at http://www.fckeditor.net/demo in source

<p><span style="font-family: Times New Roman">&ldquo;To be well-informed is to have the world at your fingers.&rdquo;</span></p>
<p><span style="font-family: Times New Roman">&mdash;Joseph Jones</span></p>
<p><span style="font-family: Times New Roman">Dear Friend,</span></p>
<p><span style="font-family: Times New Roman">Did you know that 2007 was actually the fifth highest year for home sales in history? Take a closer look at the numbers and you will discover that the state of the real estate market may not be everything the media leads you to believe. Sometimes we all need a little historical perspective to see the big picture clearly.</span></p>
<p><span style="font-family: Times New Roman">Fortunately, I did all of the research and analysis for you already. This month&rsquo;s Item of Value includes a variety of interesting and informative statistics that illustrate why last year was a good year overall for home sales. With mortgage rates historically low and new, innovative mortgage programs being unveiled, there is even greater promise for home sales in 2008.</span></p>
<p><span style="font-family: Times New Roman">On the backside, you will find a noteworthy study on the rising trend of vacation home sales. Nearly one-third of vacation homes are being purchased with the intent of becoming a full-time residence upon the buyer&rsquo;s retirement. With today&rsquo;s mortgage rates, renting options and family gathering advantages, buying a vacation home is a great option to consider.</span></p>
<p><span style="font-family: Times New Roman">With so much to take into account&shy;&shy;&shy; when you buy or sell a home, I am always available to help you sort out what is best for you.</span></p>
<p><span style="font-family: Times New Roman">Sincerely,</span></p>
<p><span style="font-family: Times New Roman"><i><b><span>Oh, by the way&reg;&hellip;if you know of someone who would appreciate the level of service I provide, please call me with their name and business number, and I&rsquo;ll be happy to follow up and take great care of them.&nbsp;</span></b></i></span></p>

And I couldn't do unbold and unitalicize in last line. Sometimes it does unbold and sometimes doesn't do it.

Change History

comment:1 follow-ups: ↓ 2 ↓ 5 Changed 7 years ago by w.olchawa

  • Keywords Pending added; unbold, unitalicize removed

Hi!

I could reproduce your bug in FF2 only. In IE and IE7 it worked fine. Could you please attach the above example in a file, so that the syntax would be more organized. It would be easier than to find out what is causing the problem and isolate what is wrong.

Thanks!

comment:2 in reply to: ↑ 1 Changed 7 years ago by mayank1711

Replying to w.olchawa:

Hi!

I could reproduce your bug in FF2 only. In IE and IE7 it worked fine. Could you please attach the above example in a file, so that the syntax would be more organized. It would be easier than to find out what is causing the problem and isolate what is wrong.

Thanks!

For me this problem was resolved when I downloaded new nighlt built version.

comment:3 Changed 7 years ago by fredck

  • Keywords Confirmed Firefox added; Pending removed
  • Description modified (diff)

comment:4 Changed 7 years ago by julia82

I'm interested too. (If this bug really corresponds to my problem, I will give details too as soon as possible)!

comment:5 in reply to: ↑ 1 Changed 7 years ago by julia82

Hello! I'm using IE6 with FCKeditor 2.5.1 and I neither can do unbold (or unstraight, unitalicize), with this example and with others.

The relevant data of my configuration file are:

FCKConfig.FormatSource=false;
FCKConfig.FormatOutput=false;

FCKConfig.EnterMode='br';
FCKConfig.ShiftEnterMode='br';

Please tell us how to solve this problem? (I'm not sure that it is fixed in any further version) or post a fix...

Thanks for your great job!

Replying to w.olchawa:

Hi!

I could reproduce your bug in FF2 only. In IE and IE7 it worked fine. Could you please attach the above example in a file, so that the syntax would be more organized. It would be easier than to find out what is causing the problem and isolate what is wrong.

Thanks!

comment:6 Changed 6 years ago by fredck

  • Status changed from new to closed
  • Resolution set to fixed

I'm not able to reproduce this problem. I'm closing this ticket as the reported confirmed it is working now.

comment:7 Changed 6 years ago by mayank1711

Thanks for taking great care of this issue. I am glad to inform you that FCKeditor is working excellent in my website www.relationshiplist.biz

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy