Ticket #1730 (closed Bug: worksforme)

Opened 7 years ago

Last modified 3 years ago

Delete 1th item from nested list

Reported by: Roman Owned by:
Priority: Normal Milestone:
Component: Core : Lists Version: FCKeditor 2.5.1
Keywords: IE Firefox Cc:

Description

I have nested list, which I create using Increase indent from standart bullet list. Sourcecode is:

<ul>
    <li>item 1-1
    <ul>
        <li>item 2-1</li>
        <li>item 2-2</li>
    </ul>
    </li>
    <li>item 1-1</li>
</ul>

When I delete first item in Wysiwyg mode then I get various results.

in IE 6.0, source code is bad, in Wysiwyg look OK:

<ul>
    <ul>
        <li>item 2-1</li>
        <li>item 2-2</li>
    </ul>
    <li>item 1-1</li>
</ul>

and If I try Decrease Indent, I get Runtime error on Line: 81, (indent is null ...) and then source code is:

<ul>
    <ul>
        <li>item 2-1&nbsp;<span id="1199966901715S" style="display: none">&nbsp;</span></li>
        <li>item 2-2</li>
    </ul>
    <li>item 1-1</li>
</ul>

in FF 2.0.0.11, source code is OK, but Wysivig look bad:

<ul>
    <li>
    <ul>
        <li>item 2-1</li>
        <li>item 2-2</li>
    </ul>
    </li>
    <li>item 1-1</li>
</ul>

Change History

comment:1 Changed 7 years ago by martinkou

  • Keywords Confirmed IE Firefox added; nested list removed

<ul><ul> ... isn't acceptable in XHTML, because it doesn't validate.

<ul><li><ul> ... validates in XHTML, but doesn't look right.

Perhaps we'll need to move "item 2-1" up one level in such cases.

comment:2 Changed 7 years ago by fredck

  • Milestone set to FCKeditor 2.7

comment:3 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy