Ticket #1813 (confirmed New Feature)

Opened 7 years ago

Last modified 2 years ago

Option to require alt text tag for images

Reported by: ptiemann Owned by:
Priority: Normal Milestone:
Component: UI : Dialogs Version:
Keywords: Confirmed Cc:

Description

In order to be accessibility compliant on a web site one should always use an alt text tag for an image. Is there any way that FCKEditor can require the tag be entered when an image is inserted?

Change History

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Discussion added

comment:2 Changed 6 years ago by arczi

  • Status changed from new to closed
  • Keywords Discussion removed
  • Resolution set to fixed

Fixed in V3 - [3512]

comment:3 Changed 6 years ago by alfonsoml

  • Status changed from closed to reopened
  • Resolution fixed deleted

No.

[3512] just brings feature parity with v2 so now an empty alt is generated by default, but real accessibility requires that each image must have a valid alt description. Putting alt="" just fools the machine validators, but this ticket is requesting than when a user creates an image, he must provide an appropriate alt description. (of course, as an option because not all sites might want to force this requirement on their users, although this is basic for accessibility)

comment:4 Changed 6 years ago by arczi

  • Keywords Confirmed added

Yes, you are right.

comment:5 Changed 2 years ago by j.swiderski

  • Status changed from reopened to confirmed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy