Ticket #1882 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Saving a page deletes all interlanguage links on that page

Reported by: evan Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Confirmed Cc:

Description

For MediaWiki, you can define certain kinds of interwiki links that won't show up in the page content. They instead get put on the "other languages" menu (by default). This is for links to translations of the article on another related wiki.

The code for an interlanguage link is identical to an interwiki link. The only way to tell one from the other is that a) the interlanguage link has "iw_local = 1" on its interwiki table row, and b) the prefix of the interlanguage link is a key in the language names array (see languages/Names.php). A common example might be, on the page "Dog", "[[fr:chien]]" to make an interlanguage link to the French version of the page.

As a first step, it would be nice to at least preserve this markup so it doesn't get lost when someone edits the page. (I'll file a separate ticket for allowing users to add, edit and delete interlanguage links.)

Change History

comment:1 Changed 6 years ago by w.olchawa

Possibly a DUP of #1543

comment:2 Changed 6 years ago by w.olchawa

  • Keywords dataloss removed

comment:3 Changed 6 years ago by w.olchawa

  • Status changed from new to closed
  • Resolution set to duplicate

I'm marking #1543 and also this one as DUP of #1883. It seems it should be placed in a new Feature

comment:4 Changed 6 years ago by evan

I strongly request that you don't make it a dupe of 1883.

#1883 is a nice-to-have feature; #1882 is a bug that deletes important information from existing pages.

Making the 1883 feature would, probably, fix this bug; however, there are other ways to do it (like caching the code that's lost in an HTML comment or somewhere on the $SESSION variable or something).

A nice UI is a lower priority than not slicing off existing, semantic data in the page.

comment:5 Changed 6 years ago by w.olchawa

  • Status changed from closed to reopened
  • Keywords Confirmed added
  • Resolution duplicate deleted

You're right Evan. I'll reopen this ticket due to your suggestions.

comment:6 in reply to: ↑ description Changed 6 years ago by Joe Beaudoin Jr.

I agree. The markup needs to be preserved, at least... I would think that this shouldn't be that difficult.

comment:7 Changed 6 years ago by Joe Beaudoin Jr.

Ok, an update... You can preserve the formatting by merely encasing your interwiki and interlanguage links in "<noinclude></noinclude>".

Of course, that's a stopgap solution, but it works. :)

comment:8 Changed 6 years ago by w.olchawa

  • Priority changed from High to Normal

comment:9 Changed 6 years ago by wwalc

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed with [1851]. Interlanguage links are now appended at the bottom of the page.

Proposal of better handling of interlanguage links is described in ticket #1883.

comment:10 Changed 6 years ago by wwalc

aditional fix for [[:de:links]] [1859].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy