Opened 7 years ago

Closed 7 years ago

#1907 closed Bug (fixed)

JavaScript errors in Firefox 3.0b3

Reported by: matthiasmiller Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6.3
Component: General Version: FCKeditor 2.5.1
Keywords: Review+ Cc:

Description

I am getting sporadic errors when loading the editor in Firefox 3.0b3. The problem is that fckeditorapi.js is appending a SCRIPT element to the parent page to bootstrap the API. However, appending the SCRIPT element appears to be an asynchronous action in Firefox, so it's not always possible to immediately access oParentWindow.FCKeditorAPI. (I discovered this because the parent page sometimes needs to load a script that takes a second or two to fetch.)

A simple solution is to remove the check for FCKBrowserInfo.IsGecko19 added in r659, since the Firefox bug has been fixed.

As an aside, I don't know if this is an issue in Safari. If it is, you might consider something like this approach.

Attachments (1)

1907.patch (1.2 KB) - added by martinkou 7 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Pending added

Hi!

Could you provide information about what error are you experiencing? You've described the origin of the problem fully however I'm not able to specify what problem you are dealing with. Also could you please write what version of FCKeditor are you using?

Thanks!

comment:2 Changed 7 years ago by matthiasmiller

I encountered this with 2.5.1 (build 17566). Firefox threw an error because oParentWindow.FCKeditorAPI was not defined, then subsequently refused to load up the editor.

comment:3 Changed 7 years ago by w.olchawa

  • Version set to FCKeditor 2.5.1

Hi again!

I'm using Firefox Beta 3 as well as you are but I didn't encounter the same problem as you did yet. However as you said it is a sporadic bug so it is hard to reproduce.

Does the problem also occur on our demo page? http://www.fckeditor.net/demo

Please let us know.

Thanks

comment:4 Changed 7 years ago by w.olchawa

  • Resolution set to invalid
  • Status changed from new to closed

Ticket expired.

comment:5 Changed 7 years ago by alfonsoml

  • Milestone set to FCKeditor 2.6.3
  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening due to http://www.fckeditor.net/forums/viewtopic.php?f=6&t=10109&start=10#p27044 and targeting for further study.

comment:6 Changed 7 years ago by martinkou

  • Owner set to martinkou
  • Status changed from reopened to new

Changed 7 years ago by martinkou

comment:7 Changed 7 years ago by martinkou

  • Keywords Review? added; Pending removed

comment:8 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:9 Changed 7 years ago by martinkou

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [2188].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy