Ticket #1926 (closed Bug: worksforme)

Opened 7 years ago

Last modified 3 years ago

[Safari] InsertHtml doesn't work first time in safari

Reported by: jdr99 Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5.1
Keywords: Safari Cc:

Description

Tested this on both the 2.51 and 2.6 beta release.

see the following page as an example: http://ritter.eplt.washington.edu/fckeditor/_samples/default.html

click the quote button (which fires off an onclick that calls InsertHtml) and nothing happens. If you click a second time the quote actually works. This only happens when using safari. So I'm really not sure if this belongs as a safari bug or a fck bug. Using safari Version 3.0.4 (5523.10.6)

Just as a note, to work around this bug you can simply call InsertHtml() with no content and then call it with the content you want.

Change History

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Confirmed Safari added
  • Version set to FCKeditor 2.5.1
  • Summary changed from InsertHtml doesn't work first time in safari to [Safari]InsertHtml doesn't work first time in safari

Confirmed using Safari 3.0.4 (523.15).

comment:2 Changed 7 years ago by w.olchawa

  • Summary changed from [Safari]InsertHtml doesn't work first time in safari to [Safari] InsertHtml doesn't work first time in safari

comment:3 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy