Ticket #1937 (closed New Feature: invalid)

Opened 6 years ago

Last modified 2 years ago

Add indent/outdent capability in toolbar as default in MediaWiki+FCKeditor

Reported by: dknezek Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

The current version of the MediaWiki+FCKeditor extension doesn't seem to include implementation of the indent/outdent (or "Increase Indent" and "Decrease Indent") buttons on the toolbar.

Editing the fckconfig.js file to add the 'Outdent' and 'Indent', then clearing the browser cache and rediting a MediaWiki page, causes the "Increase Indent" and "Decrease Indent" buttons to appear, and they do seem to work in the WYSIWYG mode (although the indent is grayed out for bulleted lists--why? Can't you just stick a <ul> </ul> pair around it to make it indented?).

However, when you switch to Wikitext mode, the corresponding ":" wikitext (or even just something like <ul> </ul> to do the same thing) do not appear, and the indentations are lost.

Indent/outdent is critical to most of the editing that I do and many others I've talked to. Is this actually not implemented in MediaWiki+FCKeditor yet? If not, please do so!

Thanks again for your efforts on bringing a decent WYSIWYG wikitext editor to us MediaWiki users!

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Confirmed added; mediawiki indent removed

comment:2 Changed 4 years ago by cneubauer

There is a comment on #2161 with a hack to make indenting work. FCKeditor was stripping the styles off of indented paragraphs.

comment:3 Changed 2 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy