Ticket #1970 (closed New Feature: fixed)

Opened 6 years ago

Last modified 6 years ago

Configuration to default border=0 for images

Reported by: csgaraglino Owned by:
Priority: Normal Milestone: CKEditor 3.0
Component: General Version:
Keywords: Confirmed Cc:

Description

Please include the ability to set a default for image borders. When linking images, and there is NO border set, the image gets an ugly border around it. It would be extremely helpful if we could have a configuration switch that would automatically default the border to zero (0).

Change History

comment:1 Changed 6 years ago by w.olchawa

  • Keywords Pending added

Hi.

I can't see this problem, because for me the appearance of the image with boreder=0 and with no border parameter set is exactly the same.

comment:2 Changed 6 years ago by csgaraglino

It is only visable when the image is a link.

<a href="file.html"><img src="file.jpg"></a> will produce a border

<a href="file.html"><img src="file.jpg" border=0></a> will produce NOT a border

If the border is always defaulted to zero, then the URL issues never becomes an issue.

comment:3 Changed 6 years ago by alfonsoml

Why don't you add img {border:0} to your stylesheet?

comment:4 Changed 6 years ago by csgaraglino

This would then cripple all image borders when one was set greate then 0 in the image properties.

Besides, it is proper HTML Coding to have border=0 as a default (just like alt=""), as is clearly defines what the browser is suposed to do with borders.

comment:5 Changed 6 years ago by fredck

  • Keywords Confirmed added; Pending removed

comment:6 Changed 6 years ago by arczi

  • Status changed from new to closed
  • Resolution set to fixed
  • Milestone set to CKEditor 3.0

Fixed with [2873].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy