Ticket #1981 (closed Bug: fixed)

Opened 7 years ago

Last modified 7 years ago

[Safari] open and close <br></br> tags

Reported by: thomp361 Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6
Component: General Version: FCKeditor 2.6 Beta
Keywords: Confirmed Safari Cc:

Description

Hi,

Using 2.6B on Safari 3.0.4 (Mac and Windows versions)

If you set .EnterMode = 'br', I am noticing that you get opening and closing <br> tags for example just type some text then switch to source view:

sample<br>
</br>text

PS - the SVN from 3/6/08 exhibits the same behavior

PSS - v2.5.1 doesn't exhibit this behavior, it works as expected.

Change History

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Confirmed Safari added; </br> removed
  • Priority changed from High to Normal
  • Summary changed from open and close <br></br> tags in Safari? to [Safari] open and close <br></br> tags

Confirmed using Safari 3.0.4. in 2.6 beta and SVN version. Works fine in 2.5.1. Other browsers don't seem to be affected.

comment:2 Changed 7 years ago by fredck

  • Milestone changed from Safari Compatibility to FCKeditor 2.6

comment:3 Changed 7 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

This is caused by the change in fckxhtml_gecko.js in [1192]. So the source of the problem in this ticket is the same as in #1989.

comment:4 Changed 7 years ago by martinkou

The patch I've posted to #1989 fixes this issue as well.

comment:5 Changed 7 years ago by martinkou

  • Status changed from assigned to closed
  • Resolution set to fixed

Fixed with [1691].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy