Ticket #202 (closed Bug: fixed)

Opened 8 years ago

Last modified 8 years ago

<HR> tag breaks source

Reported by: lyg73 Owned by:
Priority: Normal Milestone: FCKeditor 2.4.3
Component: General Version: FCKeditor 2.4
Keywords: SF IE Cc: niceguyalberto@…, bnoblet@…

Description

If html source is followed

<p>TEST1</p>
<p><hr /></p>
<p>TEST2</p>

Switch to source editing mode and WYSIWYG mode some times..

then the source of above is changed to below..

<p>TEST1</p>
<p>&nbsp;</p>
<hr />
<p>&nbsp;</p>
<p>TEST2</p>

<p>&nbsp;</p> tag is appended ...


Moved from SF:
http://sourceforge.net/tracker/index.php?func=detail&aid=1339441&group_id=75348&atid=543653

Change History

comment:1 Changed 8 years ago by fredck

you can get it also with the code

<p><font size="2">test1<hr />test2</font></p>

(in this case you get a duplication of "test2")


Moved from SF. Original poster: niceguyalberto

comment:2 Changed 8 years ago by fredck

  • Keywords IE added

I was forgetting one important detail: it seems to happen only with Internet Explorer


Moved from SF. Original poster: niceguyalberto

comment:3 Changed 8 years ago by fredck

Yes, this is the same problem I'm having. Indeed a bug. I hope it gets fixed in the next revision...

Thanks FCK programmers!

  • Seppo

Moved from SF. Original poster: anonymous

comment:4 Changed 8 years ago by fredck

Dear niceguyalberto and nobody... Thanks for your comments..

In followed case, test2 is duplicated...

<p><font size="2">test1<hr/>test2</font></p>

Moved from SF. Original poster: lyg73

comment:5 Changed 8 years ago by fredck

This also happens when submitting the form, not only when switching to / from HTML source mode. It also only happens only to the first HR within the tags that it encounters on each save/switch. The subsequent ones are fine until you submit again or switch from source to WYSIWYG mode again, that is.


Moved from SF. Original poster: anonymous

comment:6 Changed 8 years ago by fredck

UPDATE!!!

if now I try with

<p><font size="2">test1<hr
/>test2</font></p>

I do NOT get duplicated text but only extra "<p>&nbsp;</p>"

can it be for a IE patch???

(version 6.0.2800.1106CO)


Moved from SF. Original poster: niceguyalberto

comment:7 Changed 8 years ago by fredck

I also have this problem and would like to see it fixed. I can confirm it still occurs in version 2.3.


Moved from SF. Original poster: bnoblet

comment:8 Changed 8 years ago by fredck

https://sourceforge.net/tracker/index.php?func=detail&aid=1529613&group_id=75348&atid=543653
has been marked as duplicate of this bug


Moved from SF. Original poster: alfonsoml

comment:9 Changed 8 years ago by fredck

  • Cc niceguyalberto@…, bnoblet@… added
  • Reporter changed from fredck to lyg73

comment:10 Changed 8 years ago by fredck

#201 is a DUP of this one.

comment:11 Changed 8 years ago by fredck

  • Status changed from new to closed
  • Version set to FCKeditor 2.4
  • Resolution set to fixed
  • Milestone set to FCKeditor 2.4.1

I'm really happy to announce that this issue has been fixed with [194].

Click here for more info about our SVN system.

comment:12 Changed 8 years ago by fredck

  • Milestone changed from FCKeditor 2.4.1 to FCKeditor 2.5

There was an unfortunate regression of it with [219]. It has been fixed again with [321].

comment:13 Changed 8 years ago by alfonsoml

comment:14 Changed 8 years ago by fredck

  • Milestone changed from FCKeditor 2.5 to FCKeditor 2.4.3
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy