Ticket #2099 (closed Bug: invalid)

Opened 7 years ago

Last modified 7 years ago

Image Search returns full HTML in search results

Reported by: joshua.lyon Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

I am using an embedded version of MediaWiki in another application called Joomla using a Joomla plugin called TINMW (This is not MamboWiki) which integrates MediaWiki into Joomla. Other functions of MediaWiki work great, but the FCKeditor MediaWiki plugin does not fully work for me. When editing an article, if I click on the Insert/Edit Image button it pulls up the Image Properties window and it all looks fine. As I start typing in the Image File name box, the AJAX appears to start going to work, but when I stop typing and the AJAX completes, the source code for a page shows up in the search results.

I've attached my LocalSettings.php so you can see my configuration (and variables).

As a side note, this also happens with the Link component as well which appears to be a related issue. As another side note, I'm not sure if it's related, but switching back and forth between Wikitext and the rich editor does not work either. Clicking the button once, switches the user into Wikitext mode, but when you click the button to switch back it appears that the whole page (including the Joomla wrapper) is trying to be loaded within the editor.

Attachments

LocalSettings.php (5.8 KB) - added by joshua.lyon 7 years ago.
Local Settings

Change History

Changed 7 years ago by joshua.lyon

Local Settings

comment:1 Changed 7 years ago by w.olchawa

  • Keywords image, ajax, search removed
  • Status changed from new to closed
  • Resolution set to invalid

It's mostly possible that it's a bug caused by Joomal not MediaWiki+FCKeditor. You can check that this bug doesn't appear in MW and FCKeditor extension ( see http://mediawiki.fckeditor.net/index.php/Sandbox )

You could start from checking if http://host/mw/index.php?action=ajax is giving a blank page (good response) or your main page (bad response).

However since it is not a MW+FCKeditor strictly related bug I will have to close this bug.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy