Opened 9 years ago

Closed 9 years ago

#2114 closed Bug (fixed)

[IE] Dialog boxes in IE6 function only once

Reported by: abjerkho Owned by: martinkou
Priority: Must have (possibly next milestone) Milestone: FCKeditor 2.6.1
Component: UI : Dialogs Version: FCKeditor 2.6
Keywords: Confirmed IE Review+ Cc: anders@…

Description

Installed both 2.6 stable and latest nightly build. I have problems with IE6. IE7 and Firefox works fine.

In IE6 the dialogboxes for copy text, links etc only works the first time. Second time (or any time later) I only get a grey box with no form fields or buttons. It doesn't matter witch one I click first. After the first time for any box, none of the boxes works.

There is one exception. The dialog box for insert image works.

Attachments (3)

TC_2114.PNG (57.8 KB) - added by w.olchawa 9 years ago.
Screenshot of the bug
TC_2114_2.PNG (65.5 KB) - added by w.olchawa 9 years ago.
Link Dialog after clicking through the tabs
2114.patch (1.7 KB) - added by martinkou 9 years ago.

Download all attachments as: .zip

Change History (21)

comment:1 Changed 9 years ago by abjerkho

I was wrong. The dialog box for images doesn't work. There is one thing though, insert link doesn't work when I get it on screen, but I get the tabs, and when I click one of the tabs, the content in dialogbox appear, but de form input fields has wrong size. But they work.

comment:2 Changed 9 years ago by w.olchawa

  • Keywords Pending WorksForMe added; IE6 Internet Explorer 6.0 removed
  • Priority changed from High to Normal

I've tried to reproduce your bug both using IE6 and IE7 and everything seems to work fine. Can you reproduce the problem on our demo page: http://www.fckeditor.net/demo ?

Let us know what are your results. Thanks.

comment:3 Changed 9 years ago by w.olchawa

  • Keywords Confirmed IE added; Pending WorksForMe removed

Ignore my previous post. I forgot to check twice.

Confirmed using IE6. A major BUG.

Steps to reproduce:

  1. Go to our demo page http://www.fckeditor.net/demo
  1. Highlight "some"
  1. Click the "Inesert Link" button. Everything OK for now.
  1. Close the window withou inserting the link
  1. Click "Insert Link" again
  1. The dialog field is greyed. If you click on the tab option will reappear.

comment:4 Changed 9 years ago by w.olchawa

  • Priority changed from Normal to High
  • Summary changed from Dialog boxes in IE6 function only once to [IE] Dialog boxes in IE6 function only once

Changed 9 years ago by w.olchawa

Screenshot of the bug

comment:5 Changed 9 years ago by abjerkho

It works much better on the demo page than on my install. I don't use standard directories. But I didn't think that should have anything to say as it works fine in IE7 and Firefox

Changed 9 years ago by w.olchawa

Link Dialog after clicking through the tabs

comment:6 Changed 9 years ago by martinkou

  • Milestone set to FCKeditor 2.6.1
  • Owner set to martinkou
  • Status changed from new to assigned

comment:7 Changed 9 years ago by moonpool

Any chance a patch could be released for this before 2.6.1 is released - this is really a blocker ?

comment:8 Changed 9 years ago by martinkou

Funny, it seems to always work on my computers? :|

Is there any trick to make it easier to reproduce the bug?

comment:9 Changed 9 years ago by martinkou

I've done some more testing today, and I still can't reproduce the bug no matter how many times I opened and closed the dialog.

I've got a friend who said he could easily reproduce the bug though, so the bug is definitely there but it doesn't seem to affect all IE6 installations.

I'm now suspecting the bug occurs only in some IE6 versions.

My test platforms (no bug occurrence): 6.0.2900.2180.xpsp_sp2_gdr.070227-2554 (C2D E6400/WinXP in VMWare Fusion) 6.0.2900.2180.xpsp_sp2_qfe.070227-2300 (A64 3200+/Native WinXP) MultipleIE IE6 (MBP 2.2GHz/WinXP in VMWare Fusion)

My friend's test machine (buggy): 6.0.2900.2180.xpsp_sp2_rtm.040803-2158 (Unknown hardware/Native WinXP)

comment:10 Changed 9 years ago by martinkou

Oops, the wiki formatting is removing line breaks. Reposting the version information..

My test platforms (no bug occurrence):
6.0.2900.2180.xpsp_sp2_gdr.070227-2554 (C2D E6400/WinXP in VMWare Fusion)
6.0.2900.2180.xpsp_sp2_qfe.070227-2300 (A64 3200+/Native WinXP)
MultipleIE IE6 (MBP 2.2GHz/WinXP in VMWare Fusion)

My friend's test machine (buggy):
6.0.2900.2180.xpsp_sp2_rtm.040803-2158 (Unknown hardware/Native WinXP)

comment:11 Changed 9 years ago by martinkou

I can reproduce the bug now, but only when I opened IE via WinXP Remote Desktop Connection.

It's really strange, if I opened IE6 in VMWare Fusion or with a native LCD screen, I can click the Link button all day and not see the bug once. But opening IE via a Remote Desktop window I can get the bug to occur every time.

comment:12 Changed 9 years ago by martinkou

Hmm, even with remote desktop I can still only reproduce the problem on the www.fckeditor.net site, but not in my local installation. This is not really useful for debugging... I still need to find a way to reproduce the issue on a modifiable code package.

comment:13 Changed 9 years ago by w.olchawa

#2132 has been marked as DUP

you can find some screenshots of the bug in #2132 if needed

comment:14 Changed 9 years ago by abjerkho

To test, I have 2 similar implementations.

One, which works okay in IE6, - we are unable to replicate the bug here: http://demo309.skoleveven.no/skoleveven/fckeditor.php

One, which replicates the bug every time in IE6, but we don't see why: Log in with username/password: test/test here: http://demo309.skoleveven.no/skoleveven/

  • and click "News" in the menu to add an article.

Changed 9 years ago by martinkou

comment:15 Changed 9 years ago by martinkou

  • Keywords Review? added

I've written a patch which seems to fix the problem.

comment:16 Changed 9 years ago by abjerkho

I've also the patch and looks like the bug is fixed. So far we haven't been able to reproduce the bug anymore.

comment:17 Changed 9 years ago by alfonsoml

  • Keywords Review+ added; Review? removed

I haven't tested it as it seems to require a quite specific configuration, but I guess that if both of you say that it's working then I can give it a review+

comment:18 Changed 9 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [1945].

Click here for more info about our SVN system.

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy