Ticket #2142 (closed New Feature: fixed)

Opened 7 years ago

Last modified 6 years ago

HTML samples should use php extension in action paramter inside a form

Reported by: w.olchawa Owned by: w.olchawa
Priority: Normal Milestone: FCKeditor 2.6.1
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Review+ Cc:

Description

My suggestion is to replace sampleposteddata.asp with sampleposteddata.php in action parameter inside the form. I think that the usage of asp extension is less useful for the users. I don't know what is the most common used server side however I think that PHP is more popular than ASP (more of the users use Appache rather than IIS for example). Of course a user could always use the php examples however I don't see why php extension couldn't be used in html samples as well.

Attachments

2142.patch (12.2 KB) - added by w.olchawa 7 years ago.
2142_2.patch (12.6 KB) - added by w.olchawa 7 years ago.
Patch proposal

Change History

comment:1 Changed 7 years ago by fredck

  • Keywords Confirmed added; Discussion removed
  • Milestone set to FCKeditor 2.6.1

It makes a lot of sense. PHP is definitely the most used language, related to the editor (we have done a research about it previously).

comment:2 Changed 7 years ago by w.olchawa

  • Owner set to w.olchawa

comment:3 Changed 7 years ago by w.olchawa

I've attached a patch proposal. The patch should throw an error when trying to modify sampleposteddata.asp from _samples/html catalog. (because of attempt to delete it). However it shouldn't be a problem when committing the patch.

Changed 7 years ago by w.olchawa

comment:4 Changed 7 years ago by w.olchawa

  • Keywords Review? added

comment:5 Changed 7 years ago by alfonsoml

  • Keywords Review+ added; Review? removed

Please, update the what's new file remarking that it's an important change from previous versions.

comment:6 Changed 7 years ago by w.olchawa

  • Status changed from new to closed
  • Resolution set to fixed

Fixes with [1947]

comment:7 Changed 7 years ago by alfonsoml

  • Status changed from closed to reopened
  • Resolution fixed deleted

Now I think that instead of copying the sampleposteddata.php it would be better to change the action so it points to ../php/sampleposteddata.php

That way there's only one copy of that file and it's absolutely clear for anyone what to do if they are working with other languages.

comment:8 Changed 7 years ago by w.olchawa

Good point I will provide a new patch in a few minutes

comment:9 Changed 7 years ago by w.olchawa

  • Keywords Review+ removed

comment:10 Changed 7 years ago by w.olchawa

  • Keywords Review? added

I don't see any reason for keeping sampleposteddata.html as well. I have applied changes to the patch.

Changed 7 years ago by w.olchawa

Patch proposal

comment:11 Changed 7 years ago by alfonsoml

  • Keywords Review+ added; Review? removed

comment:12 Changed 6 years ago by w.olchawa

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed with [1957]

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy