Ticket #2154 (closed Bug: duplicate)

Opened 7 years ago

Last modified 6 years ago

Empty editor submits "<p>&#160;</p>" when ProcessHTMLEntities is false

Reported by: geirhelge Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6
Keywords: Confirmed Cc:

Description

How to reproduce:

  1. Set FCKConfig.ProcessHTMLEntities to false and let the editor be empty at start up
  2. Load the editor
  3. Switch to source view and observe that the source is "<p>&#160;</p>" or submit and you'll get the same result.


Is this intentionally? We can't let the FCKConfig.ProcessHTMLEntities be true because our Norwegian characters will be processed and unsearchable (unless we do some post processing).

Reproduced in Firefox 2.0.0.14 on Ubuntu and IE 7 on MS Vista.

Expected result: Empty post as when FCKConfig.ProcessHTMLEntities is true.

Change History

comment:1 Changed 7 years ago by w.olchawa

  • Keywords Confirmed added

Confirmed using FCKeditor 2.6 and the latest SVN version in FF2 and IE.

comment:2 Changed 7 years ago by w.olchawa

#2231 has been marked as DUP

comment:3 Changed 6 years ago by wwalc

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1660.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy