Opened 7 years ago

Closed 4 years ago

#2244 closed Bug (invalid)

FCKeditorAPI::InitializeAPI, work inside nested iframes

Reported by: Scott Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5
Keywords: HasPatch Cc:


If you load fckeditor inside nested iframes, and create and destroy instances of fckEditor, some really really wierd things can go on which mess up the form.submit() method.

Can I suggest changing the API to use the absolute topmost window object of the browser.

See attached patch.

Attachments (1)

fckapi.patch (764 bytes) - added by Scott 7 years ago.

Download all attachments as: .zip

Change History (3)

Changed 7 years ago by Scott

comment:1 Changed 5 years ago by wwalc

  • Version set to FCKeditor 2.5

comment:2 Changed 4 years ago by j.swiderski

  • Resolution set to invalid
  • Status changed from new to closed

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy