Ticket #2288 (closed Bug: invalid)

Opened 6 years ago

Last modified 5 years ago

Nested formatting goes wrong

Reported by: dommisse Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version:
Keywords: Pending WorksForMe Cc:

Description

If a user wants to do more than one format on the same substring the formatting will at least partial show in the editor, but after submitting the formatting does not show up on the result. The code produced looks like: <span style="font-family: Comic Sans MS;"><span style="color: rgb(255, 0, 255);"><span style="font-size: 5px;">some text</span></span></span> It seems that the styles from the cascading spans are not inherited in the browser. If the code is simplified to: <span style="font-family: Comic Sans MS; color: rgb(255, 0, 255); font-size: 5px;">some text</span> the formatting will be show up as expected. I have seen this in IE, Firefox, Opera and Safari so I really think yhis is a FCKeditor thing.

Tested with version 2.6.1

Kees

Change History

comment:1 Changed 6 years ago by fredck

  • Keywords Pending WorksForMe added
  • Component changed from General to Core : Styles

I'm not able to replicate this problem. It just works well for me with the online demo in IE and Firefox.

Do you have more information on this? What are the precise steps to reproduce it here?

comment:2 Changed 6 years ago by dommisse

You can see it working on http://www.dommis.nl/home.php?page=0027 and http://www.dommis.nl/home.php?page=0022 I have put the generated code (and the fixed code) beneath the examples

Strange thing is that all shows well in the editor screen, but not embedded in the page where it is shown.

comment:3 Changed 5 years ago by alfonsoml

  • Status changed from new to closed
  • Resolution set to invalid

The problem is your css:

body, p, div, span {
 color:#000000;
 font-family:Tahoma,Geneva,sans-serif;
 font-size:medium;
}

So the inner span resets the values of the external spans.

There are other bugs about merging the generated styles instead of nesting them.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy