Ticket #2307 (closed Bug: wontfix)

Opened 6 years ago

Last modified 6 years ago

RTL: Click on Link dialog tabs enlarge the dialog width

Reported by: fredck Owned by: martinkou
Priority: Normal Milestone:
Component: UI : Dialogs Version: SVN (FCKeditor) - Retired
Keywords: Confirmed Firefox CantFix Cc:

Description

With FF3, when in RTL, like when loading the Arabic localization, if you click on a dialog tab the Link dialog enlarges on its width. Each click enlarges it s few pixels.

No problem with IE.

Change History

comment:1 Changed 6 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

comment:2 Changed 6 years ago by martinkou

It seems to work ok on Firefox 3/Windows XP here... I can click on the tabs in the Link dialog indefinitely and the dialog wouldn't expand.

On Firefox 3/Mac OS X the dialog expanded once when I clicked on the third tab, but subsequent clicks wouldn't expand it further.

comment:3 Changed 6 years ago by fredck

  • Status changed from assigned to closed
  • Keywords CantFix added
  • Resolution set to wontfix
  • Milestone FCKeditor 2.6.3 deleted

It turned out that this bug is caused by the Resizeable Textarea extension for Firefox (version 0.1d). It is adding 8px to innerDoc.body.scrollWidth in the RefreshSize function of the dialog system.

It happens with FF3 only. No problems with FF2.

This is something that wen can't fix at our side. I'm contacting the extension author to inform him about this issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy