Ticket #2351 (closed Bug: worksforme)

Opened 6 years ago

Last modified 6 years ago

AutoDetectLanguage, not using "first available language"

Reported by: Christine.Hill Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: WorksForMe Cc:

Description

My system (Windows XP)language was set to Mexican Spanish and AutoDetectLanguage was set to true but the translation in es.js did not display, en.js was used instead. I did the same test with Canadian French and fr-ca.js was used. Of course, I was testing with IE 7.

Attachments

lang_ie.png (56.2 KB) - added by fredck 6 years ago.
Screenshot of IE7 with OS set to Mexican Spanish

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by w.olchawa

  • Keywords Pending WorksForMe added

Could you please specify what is the language of your browser? FCKeditor will set the language to the browsers language, so probably in your case it is an expected behaviour. Please let us know.

Thanks in advance

comment:2 in reply to: ↑ 1 Changed 6 years ago by fredck

  • Status changed from new to closed
  • Keywords Pending removed
  • Resolution set to worksforme

Replying to w.olchawa:

FCKeditor will set the language to the browsers language

This is true with all browsers except IE. IE takes the language from the OS, so the reported issue would be valid, if confirmed.

I've test it here and it works for me. The es.js file is loaded if the OS is set to es-mx. To check it, just use the editor about dialog. I'm attaching a screenshot with the results I'm having with our online demo and IE7.

Changed 6 years ago by fredck

Screenshot of IE7 with OS set to Mexican Spanish

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy