Ticket #2367 (closed Bug: worksforme)

Opened 6 years ago

Last modified 3 years ago

IE: List padding may cause list command errors

Reported by: fredck Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.2
Keywords: IE Cc: mistaib@…

Description

When applying "padding" and "margin" styles to list elements, IE may "expand" them, making it possible to place the caret "after" sub-lists in nested lists. Other browsers don't make it possible.

The problem is that this uncommon caret position breaks the list commands.

Steps to Reproduce

  1. Load the following HTML in the editor:
<style type="text/css">

ol
{
	padding-bottom: 20px;
}

</style>
<ol>
	<li>Item 1
		<ol>
			<li>Item 1.1</li>
		</ol>
	</li>
</ol>
<p>
	Some text.
</p>
  1. In WYSIWYG mode, place the caret in the white space following "Item 1.1". This can be achieved either by mouse click or by using the RIGHT-ARROW key.
  2. Hit any of the list buttons in the toolbar.

A JavaScript error will be thrown and nothing else happens.

Change History

comment:1 Changed 6 years ago by fredck

  • Cc mistaib@… added

comment:2 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

WFM with CKE3.2.6Trunk

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy