Ticket #2384 (closed Bug: worksforme)

Opened 6 years ago

Last modified 6 years ago

Tag object: Switching to wysiwyg mode changes param "movie" to "about:blank"

Reported by: jkufner Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.6.2
Keywords: Pending WorksForMe Cc:

Description (last modified by alfonsoml) (diff)

Hello,

try insert this code to fckeditor in source mode and switch to wysiwyg and back. (It is same when form is loaded.)

<object width="320" height="240" align="" classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" id="movie">
  <param name="movie" value="http://www.prokrasnetelo.cz/data/player.swf?file=/data/reportaz-vareni.flv&amp;size=false&amp;aplay=false&amp;autorew=true&amp;title=" />
  <param name="bgcolor" value="#ffffff" />
  <embed width="320" height="240" align="" bgcolor="#FFFFFF" src="http://www.prokrasnetelo.cz/data/player.swf?file=/data/reportaz-vareni.flv&amp;size=false&amp;aplay=false&amp;autorew=true&amp;title=" quality="high" name="movie" type="application/x-shockwave-flash" plug="" inspage="http://www.macromedia.com/go/getflashplayer">
  </embed> 
</object>

It will change <param name="movie" value="..."> to <param name="movie" value="about:blank"> so there is no way to edit texts with videos by our users.

Thank you!
Josef Kufner.

Change History

comment:1 Changed 6 years ago by alfonsoml

  • Priority changed from High to Normal
  • Keywords Pending WorksForMe added
  • Description modified (diff)

I've tested the four browsers and it's working fine for me in all of them.

Could you please provide any additional info to reproduce the issue?

comment:2 Changed 6 years ago by fredck

  • Status changed from new to closed
  • Resolution set to expired

comment:3 Changed 6 years ago by jkufner

  • Status changed from closed to reopened
  • Version changed from FCKeditor 2.6.2 to FCKeditor 2.6.3
  • Resolution expired deleted

Hello again and sorry for that looong delay...

I tested current demo (http://www.fckeditor.net/demo) for this bug in this way:

  1. open http://www.fckeditor.net/demo
  2. click "Add/edit Flash" toolbar button
  3. enter /_userfiles/flash/Yellow_Runners.swf to URL input, click ok
  4. click "Source" toolbar button, tag embed has src="/_userfiles/flash/Yellow_Runners.swf"
  5. click "Source" toolbar button twice (switch to wysiwyg and back to source)
  6. now tag embed has src="about:blank"

I used Iceweasel 3.0.1 and Iceape 1.1.12 (Mozilla and Firefox from Debian Linux).

When I use Arora 0.4 (webkit), Firefox 3.0.3 (from Solaris) or IE 6.0, it works correctly.

comment:4 Changed 6 years ago by jkufner

Hm, i've tested it with clean profile but with same extensions (both icewasel and iceape) and it works.

comment:5 Changed 6 years ago by alfonsoml

  • Status changed from reopened to closed
  • Version changed from FCKeditor 2.6.3 to FCKeditor 2.6.2
  • Resolution set to worksforme

So it's a problem with your profile, and not a bug in the editor.

BTW, the version field reflect the oldest version where the bug is present, it doesn't make sense to bump it, because if the bug isn't present in the current version then the ticket should be closed. That way it's possible to track when a bug was introduced.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy