Ticket #2489 (closed Bug: invalid)

Opened 6 years ago

Last modified 6 years ago

CKFinder upload limit cannot be changed

Reported by: arnout82 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I tried to increase the upload limit in the config file of CKFinder. I want the upload limit to 8M. I use FCK editor 2.6.x (date 2/13/2008) with ASP and CKFinder 3.x (date 6/25/2008). On the server side i use Windows Server 2003 and IIS 6.0.

This is what i have done:

  • In the wwwroot i go to /ckfinder/config.asp
  • I change the DefineResourceType declaration from "" to "8M", i also tried full bytes like: 1024*1024*8= 8388608 and "8388608".

Code look like this:

Set ResourceTypes(0) = DefineResourceType( _

"Files", _ baseUrl & "file", _ baseDir & "file", _ "8M", _ "asf,avi,doc,fla,flv,mov,mp3,mp4,mpeg,mpg,pdf,ppt,ram,rar,rm,rtf,swf,txt,wav,wma,wmv,xls,zip", _ "" _ )

CKFinder_Config.Add "ResourceType", ResourceTypes

' Helper function to return a dictionary with all the properties. Function DefineResourceType(name, url, directory, maxSize, allowedExtensions, deniedExtensions)

Dim ResourceType Set ResourceType = server.CreateObject("Scripting.Dictionary") ResourceType.Add "name", name ResourceType.Add "url", url ResourceType.Add "directory", directory ResourceType.Add "maxSize", maxSize ResourceType.Add "allowedExtensions", allowedExtensions ResourceType.Add "deniedExtensions", deniedExtensions

Set DefineResourceType = ResourceType

End function

  • But after saving the changes i still cannot upload larger files than 2 MB.
  • I tested if i had changed the correct config file so it block some extension to be sure its the right file. And that workt fine. But upload limit cannot be changed?

Change History

comment:1 Changed 6 years ago by alfonsoml

  • Keywords **CantFix** removed
  • Status changed from new to closed
  • Version FCKeditor 2.6.3 deleted
  • Resolution set to invalid
  • Milestone CKEditor 3.x deleted

This is not the place to report problems with CKFinder, you should use its forum: http://www.fckeditor.net/forums/viewforum.php?f=10

You can find there this post: http://www.fckeditor.net/forums/viewtopic.php?f=10&t=10030&hilit=size#p26375 but if you were affected by it, then the maximum size should be 1Mb, so I guess that the problem is that your IIS is limiting the maximum upload, so you should try this solution http://www.fckeditor.net/forums/viewtopic.php?f=10&t=9930&hilit=size#p26110

Please, post there about any problem with CKFinder.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy