Ticket #266 (closed Bug: invalid)

Opened 8 years ago

Last modified 7 years ago

Rowspan function

Reported by: nick.thorley Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.4
Keywords: SD-COE Cc: pkdille, Jyhem, nyloth

Description

When creating a table and you choose to merge rows together in one column the software adds a new column at the end of the table with the top cell not useable. No extra column should be added

Change History

comment:1 in reply to: ↑ description Changed 8 years ago by nick.thorley

Actually it isnt adding a new column but is only removing the <td> from the first cell in the column and leaving it in further rows and hence leaves an added column of unremoved <td> tags

Replying to nick.thorley:

When creating a table and you choose to merge rows together in one column the software adds a new column at the end of the table with the top cell not useable. No extra column should be added

comment:2 Changed 7 years ago by fredck

  • Keywords Pending added; table removed
  • Priority changed from High to Normal

I'm not able to reproduce it. Actually, I didn't understand the problem well. I've been trying to do merges on many different ways, but I couldn't face the described behavior.

Can you give a precise example on how to merge the cells to see the problem?

comment:3 follow-up: ↓ 4 Changed 7 years ago by nick.thorley

I have just reproduced it on the demo. If you create a table 10 rows 10 cols then try to merge all of the cells in one column and you get extra cells on the right hand side which you have to delete one by one (this is when you do cell properties on the top cell and then do span 10 rows. If i highlight all cells in one column and do merge cells then nothing happens.

comment:4 in reply to: ↑ 3 Changed 7 years ago by fredck

  • Status changed from new to closed
  • Keywords Pending removed
  • Resolution set to invalid

Replying to nick.thorley:

I have just reproduced it on the demo. If you create a table 10 rows 10 cols then try to merge all of the cells in one column and you get extra cells on the right hand side which you have to delete one by one (this is when you do cell properties on the top cell and then do span 10 rows.

You are using the "Rows span" field in the wrong way actually. It is used to specify the number of rows that cell needs to span. It is not used to merge, so the cells above it simply get moved to the right when doing so. This is the expected behavior of it.

If i highlight all cells in one column and do merge cells then nothing happens.

There is no way to merge cells vertically with the current version. I believe we already have a ticket for implementing it (maybe on SourceForge).

comment:5 Changed 7 years ago by fredck

  • Keywords SD-COE added

comment:6 Changed 7 years ago by fredck

  • Cc Pascal.KUSTNER@… added

comment:7 Changed 7 years ago by fredck

  • Cc jean-marc.libs@…, patrice.weber@… added

comment:8 Changed 7 years ago by fredck

  • Cc pkdille, Jyhem, nyloth added; Pascal.KUSTNER@…, jean-marc.libs@…, patrice.weber@… removed
Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy