Ticket #2720 (closed Bug: worksforme)

Opened 6 years ago

Last modified 3 years ago

Cursor jumps around on IE after pasting entire paragraphs into inline-formatted sections

Reported by: thiloplanz Owned by:
Priority: Normal Milestone:
Component: Core : Styles Version: FCKeditor 2.4
Keywords: IE Cc:

Description

  1. Into a blank editor
    • enter "aaaa" (first paragraph)
    • press return
    • enter "bbbb" (second paragraph)
    • select "aaaa" and make it bold
    • select "bbbb" (the whole line) and copy (ctrl-c)
    • move the cursor to the end of "aaaa" and paste (ctrl-v)
    • this creates a new second paragraph (bold bbbb)
  1. You have now created the following HTML (although you cannot verify that in the source view, as that rewrites the HTML which removes the boldness from new second paragraph). Note how the strong tag stretches across paragraphs.
<P><STRONG>aaaa</P>
<P>bbbb</P></STRONG>
<P>bbbb</P>
  1. Place the cursor at the end of second or third paragraphs and press enter. The cursor jumps to the top, creating a new line there instead. Place the cursor at the end of the first line and press enter and the order of the paragraphs changes.

Note: This seems to be IE-only.

Change History

comment:1 Changed 6 years ago by arczi

  • Keywords Confirmed IE added
  • Version changed from FCKeditor 2.6.3 to FCKeditor 2.4

comment:2 Changed 6 years ago by thiloplanz

This seems to be caused by the issue described in #2727.

comment:3 Changed 3 years ago by krst

  • Status changed from confirmed to closed
  • Resolution set to worksforme

FCKeditor was retired and is no longer supported. All active development was moved to its successor, CKEditor 3.x, that is a fully mature and far superior product. We recommend you upgrade as soon as possible since this issue is no longer a problem in current code base.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy