Ticket #2812 (closed Bug: invalid)

Opened 6 years ago

Last modified 3 years ago

internal wiki links - forced capitals problem

Reported by: MikeD Owned by:
Priority: Normal Milestone:
Component: Project : MediaWiki+FCKeditor Version:
Keywords: Cc:

Description

our documents are full of internal linking "shortcuts" where the users have put in things like

[[river]]

used to be that the parser would treat it as a valid wikilink in the form of

[[river|River]] 

where river was the text to be displayed and River was the document name. and all was well. (hope I have the text/link order right in the wikilink example above)

so a sentence in a document like

MikeD went down to the [[river]] to fish

displayed correctly after the document was saved and in view mode the word 'river' in the sentence was correctly linked to the document River.

now I'm getting "MikeD went down to the River to fish"

I've attepted to confirm that this is an FCK issue. Installed a fresh copy of MW 1.12.3, created new db, created 2 documents Mike and River, and then placed the wikitext shown above into the document titled Mike using the native MW editor. wikilinks work normally as expected and I see 'river' as the linked text to the document titled River.

Then install latest SVN version of FCK/MW (2989) and then add require_once $IP . "/extensions/FCKeditor/FCKeditor.php"; to localsettings.php and reload the doc titled Mike and get to the edit tab, the wikilink changes to River as the linked text and River as the document title.

Change History

comment:1 Changed 6 years ago by arczi

  • Keywords Confirmed added

comment:2 Changed 6 years ago by sonoramike

  • Component changed from General to Project : MediaWiki+FCKeditor

initially put in the wrong component area, updated to MW+FCK

comment:3 Changed 3 years ago by j.swiderski

  • Status changed from confirmed to closed
  • Resolution set to invalid

Since FCKeditor is no longer supported and was replaced with CKEditor, active development of the MediaWiki extension and support for it are also finished.

I’m closing this ticket as it is no longer valid.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy