Ticket #2828 (closed Bug: expired)

Opened 6 years ago

Last modified 3 years ago

Full Screen Editor moves off screen

Reported by: lancehudson Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: batman42ca@…

Description

When I edit a page sometimes the editor moves of screen and I can no longer see the toolbar. I do have the Doc type specified on the first line of the document.

I have attached a screen shot of the editor while showing the problem. It does not happen every time. Most often I see it happen when I drag and drop an element on the page I don't know if it is the table or the div.

I use drupal 5.14, with the current stable version of the editor, and of the fckeditor module for drupal. I have tried the nightly and experienced the same issues. This problem occurs in IE.

A link to my editor is http://www.read-write.cdp.com/devel/node/59/edit

I am unable to reproduce on the test site here. What else should I check or try.

Attachments

Untitled.jpg (96.0 KB) - added by lancehudson 6 years ago.
Safari_with_5px_bottom_border.png (264.0 KB) - added by neym 5 years ago.
Safari with an override forcing only a 5px bottom border; the toolbar is pushed up by 5px

Change History

Changed 6 years ago by lancehudson

comment:1 Changed 6 years ago by arczi

  • Keywords WorksForMe added

I was unable to reproduce this bug (IE7, vista32bit).

comment:2 Changed 6 years ago by lancehudson

I have created a screen cast of me repoducing the problem. Hopefully you will be able to use it to better diagnoise the issue.

http://www.snapback.cdp.com/users/lhudson/repo.swf.html

Thanks

comment:3 Changed 5 years ago by neym

I can confirm this same issue is happening on Safari 3.1.2 and Safari 4 (Mac versions tested) with our website. From my research with Safari 4's developer tools, it appears that Safari is placing the tool bar between several hundred to several thousand pixels above the top of the window. Safari is also improperly reporting the height of the window as significantly larger than it actually is, sometimes as high as 5000 or 6000 pixels when the screen is actually only around 1000 pixels in height.

As with the IE report, it is not reproducable on the demo site.

It appears that the underlying page layout affects the result of the browser's window size lookup, which should be consistant regardless of page layout. I have not been able to determine what of the page content is causing Safari's improper page height calculation.

comment:4 Changed 5 years ago by neym

Additional information: When Safari resizes to full screen, it is adding an 1807px border to the right and bottom of the iframe. This border is what is causing the problem. If, by overriding the iframe border in your CSS stylesheet to force it to size 0, it works in Safari.

comment:5 Changed 5 years ago by neym

Isolated specific cause: In Safari, the bottom border is treated as "must be on screen" when height=100%. Thus if your border is greater than your visible area for the height=100% object (in this case an iframe), it makes everything invisible. In the case of Safari, it is setting a 1807px high bottom border on a screen that is only 1280px high (including browser chrome).

I do not know if this will fix Lance Hudson's IE problem, since I have never encountered the IE problem myself.

Changed 5 years ago by neym

Safari with an override forcing only a 5px bottom border; the toolbar is pushed up by 5px

comment:6 Changed 4 years ago by batman42ca

  • Cc batman42ca@… added

This is an old bug but I discovered something new to add.

I had a table in my content area. In Firefox (3.6.12), in full screen mode, when I clicked below the table, I would see the described effect. The editor would seem to expand such that the toolbars were off the screen. This is 100% repeatable for me in Firefox, but does not occur in IE7.

When investigating, I noticed that I was trying to load a style sheet into the editor that did not exist. When I corrected that, the bug went away.

comment:7 Changed 3 years ago by j.swiderski

  • Status changed from pending to closed
  • Resolution set to expired

Doesn't seem to occur in latest CKEditor 3.6.2. Closing this as expired.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy