Opened 8 years ago

Closed 7 years ago

#2874 closed Bug (fixed)

tables: in FF caption seems to be in the wrong place

Reported by: trumbitta Owned by: martinkou
Priority: Normal Milestone: FCKeditor 2.6.5
Component: General Version: FCKeditor 2.6.4
Keywords: Confirmed HasPatch Review+ Cc:

Description

FCKeditor generates the following

    <table ....>
        <thead>
            <tr>
                <th scope="col">1</th>
                <th scope="col">2</th>
            </tr>
        </thead>
        <caption>My Caption</caption>
        <tbody>
            <tr>
                <td>...</td>
                <td>...</td>
            </tr>
        </tbody>
    </table>

The following would be the correct markup

    <table ....>
        <caption>My Caption</caption>
        <thead>
            <tr>
                <th scope="col">1</th>
                <th scope="col">2</th>
            </tr>
        </thead>
        <tbody>
            <tr>
                <td>...</td>
                <td>...</td>
            </tr>
        </tbody>
    </table>

Going further with my tests, I just found that the bug doesn't show up if you use MSIE7. My conclusions:

  • the problem is strictly related to the browser and its "DOM engine"

OR

  • the problem is inside the portion of code dedicated to gecko

Attachments (2)

2874.patch (2.5 KB) - added by martinkou 7 years ago.
2874_2.patch (837 bytes) - added by kwillems 7 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 8 years ago by fredck

  • Keywords Confirmed HasPatch added

comment:2 Changed 7 years ago by martinkou

  • Owner set to martinkou
  • Status changed from new to assigned

Changed 7 years ago by martinkou

comment:3 Changed 7 years ago by martinkou

  • Keywords Review? added

comment:4 Changed 7 years ago by garry.yao

  • Keywords Review+ added; Review? removed

comment:5 Changed 7 years ago by martinkou

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [3897].

Click here for more info about our SVN system.

comment:6 Changed 7 years ago by kwillems

Please re-open this one. Tested it in Firefox 3.5 but it still produces an invalid result.

To reproduce: Create a table with a caption but without any thead and th-cell. Then, edit the table and make the first row a thead filled with th-cells. In that case, the caption is placed after the thead.

Changed 7 years ago by kwillems

comment:7 Changed 7 years ago by kwillems

Added a patch. As far as I can see all is working fine now!

comment:8 Changed 7 years ago by kwillems

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:9 Changed 7 years ago by fredck

  • Resolution set to fixed
  • Status changed from reopened to closed

@kwillems, thanks for the fix. Committed with [4229].

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy