Ticket #2926 (closed Bug: expired)

Opened 6 years ago

Last modified 5 years ago

Incorrect conversion of Hex(A0) and other values

Reported by: kopavi Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Pending Cc:

Description

On windows machines both firefox and IE, data put in a form field either text or textarea that contans &nbsp; is converted to hex(A0) when saved. fckEditor then converst this value to &Acirc;. If that same value is opened in a browser form field again the browser converts this to hex(c3). fckEditor then converts this to Â... I have seen many threads in the blog about the appearance of  and this is one of the main things. Many of us wind up using the content in both browser <textarea> tags and fckEditor. When doing this the data gets corrputed and it excallates. I have composed a lengthy outline of this issue if you would like it. I feel this is a bug in both the browsers treatment and fckEditor. There are other values this happens with besides &nbsp; but this is the most common because fckEditor puts &nbsp; in all over the place.

Change History

comment:1 Changed 6 years ago by alfonsoml

  • Keywords Pending added

Can you provide a simple step by step procedure to reproduce the problem?

comment:2 Changed 5 years ago by fredck

  • Status changed from new to closed
  • Resolution set to expired

comment:3 Changed 5 years ago by IanLiu

I've solved this bug by attaching a <meta http-equiv="Content-Type" contet="text/html; charset=UTF-8" /> in <head>...</head>.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy