Opened 8 years ago

Closed 7 years ago

#3053 closed Bug (fixed)

Safari 4 improperly sets height of editor area

Reported by: neym Owned by: alfonsoml
Priority: Normal Milestone: FCKeditor 2.6.5
Component: General Version: FCKeditor 2.6.4
Keywords: WebKit Review+ Cc:

Description

Tested on Safari 4 Windows and Webkit nightly build Mac. Issue occurs when pasting text or typing text.

To reproduce:

  1. Open FCKEditor Demo page http://www.fckeditor.net/demo/toolbar?toolbar=Basic
  1. Type or paste text into editor. Text will be 1 line too short to fill proper box size.
  1. Resize Safari window. Editor area will suddenly expand to fill entire box.

Note 1: If it does not happen, try shift-reload first. It only happens on the first non-cached load of the page.

Note 2: Some editor layouts have no issues, some editor layouts have significant sizing issues, some over with the editor area 1 inch screen height too small.

See attached file for an extreme case.

Attachments (3)

FCKEditor2.6.4_Safari.png (18.8 KB) - added by neym 8 years ago.
Sample screenshot of error in Windows Safari. Editor should be nearly entire height of screenshot.
3053.patch (2.6 KB) - added by alfonsoml 7 years ago.
Proposed patch
3053_2.patch (3.0 KB) - added by alfonsoml 7 years ago.
Proposed patch

Download all attachments as: .zip

Change History (10)

Changed 8 years ago by neym

Sample screenshot of error in Windows Safari. Editor should be nearly entire height of screenshot.

comment:1 Changed 7 years ago by thisisjoel

See this thread for a similar problem with couple of workarounds - it could be useful

http://www.fckeditor.net/forums/viewtopic.php?f=6&t=13222

comment:2 Changed 7 years ago by alfonsoml

  • Milestone set to FCKeditor 2.6.5

comment:3 Changed 7 years ago by alfonsoml

#4157 has been marked as dup

Changed 7 years ago by alfonsoml

Proposed patch

comment:4 Changed 7 years ago by alfonsoml

  • Keywords WebKit added; safari webkit removed
  • Owner set to alfonsoml
  • Status changed from new to assigned

The patch basically changes the editor.html to allow the onresize to be called by both Firefox and Safari (note that the !Opera was useless as Gecko is defined as "gecko and !opera and !safari")

The two other changes to use the existence of window.onresize to call it instead of calling it only for gecko, and finally, I had to add a now manual call to window.onresize() in the fitscreen plugin because webkit didn't react to the change of dimensions.

Tested with Safari 4 in Mac and Windows and Chrome 2 in windows (remember to clear the cache on every test as these browsers really love their cache)

umm :-(

not ready for review yet. It doesn't work for example resizing the main window if the editor is maximized. (it sounded strange to me the need to manually call the code in the fitscreen code)

Changed 7 years ago by alfonsoml

Proposed patch

comment:5 Changed 7 years ago by alfonsoml

  • Keywords Review? added

Ok, this version is ready to be tested by anyone that cares. The problem in the first approach was that e.originalTarget doesn't exist (at least sometimes).

comment:6 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

comment:7 Changed 7 years ago by alfonsoml

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed with [4223]

Note: See TracTickets for help on using tickets.
© 2003 – 2016 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy