Opened 7 years ago

Closed 7 years ago

#3212 closed Bug (fixed)

CKReleaser is breaking hotkeys in CKEditor

Reported by: martinkou Owned by: wwalc
Priority: High Milestone: CKEditor 3.0
Component: General Version: SVN (CKEditor) - OLD
Keywords: Oracle Review+ Cc: Senthil


To reproduce:

  1. Add Tab_Issue.2.html to the _samples directory of SVN trunk.
  2. Compress the trunk with CKReleaser.
  3. Open Tab_Issue.2.html within the release package.
  4. Press Tab and Shift-Tab from inside the editing area, you'll see different buggy behaviors described in #3132.
  5. Press Ctrl-B in the editing area. You'll see other buggy behaviors depending on the browser.

Attachments (1)

3212.patch (598 bytes) - added by wwalc 7 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 7 years ago by wwalc

  • Owner set to wwalc

Changed 7 years ago by wwalc

comment:2 Changed 7 years ago by wwalc

  • Keywords Review? added

The problem was in invalid redeclaration of the cancel variable.

As a result CKPackager renamed the cancel variable to another letter and used that letter in

if ( cancel )
	event.preventDefault( true );

which caused invalid results.

There is no need to redeclare this variable.

comment:3 Changed 7 years ago by fredck

  • Keywords Review+ added; Review? removed

Oppss... it looks like we need a jslint run here.

comment:4 Changed 7 years ago by wwalc

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [3291].

Note: See TracTickets for help on using tickets.
© 2003 – 2015 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy