Ticket #3217 (closed Bug: duplicate)

Opened 6 years ago

Last modified 5 years ago

Unexpected <br> will be added to the RichText field if the RichText field is in source/XML view before the spell checking

Reported by: Steve.Organ Owned by:
Priority: Normal Milestone:
Component: General Version: FCKeditor 2.5 Beta
Keywords: Cc: sorgan@…

Description

Clicking the "Source" button of the empty RichText field before spell-checking and you will get the &lt;br&gt; into the empty RichText field unexpectedly. - Continue to do the spell checking and then save the doc - Preview the doc and you will see the unexpected &lt;br&gt; text showing up in the RichText field (which supposed to be empty/blank

Steps to reproduce:

  1. Download the attachment sample01.html, put to <FCKEditor_HOME>/_samples/html/(replace the default one).
  1. Open the <FCKEditor_HOME>/fckconfig.js, change the entermode as "br".
  1. Open <FCKEditor_HOME>/_samples/default.html, clean the textarea, and click the button "testF", then click the source button.

What the button "testF" did are similar with spellcheck, it will invoke the function fck.GetXHTML().

This should be a fckeditor defect the fact that this function inserts an entermode node into the textarea if the entermode is "br".(If the entermode is p, then it is OK)

Regards,

Steve

Change History

comment:1 Changed 6 years ago by Steve.Organ

  • Cc sorgan@… added

comment:2 Changed 6 years ago by mosipov

  • Milestone FCKeditor.Java 2.5 deleted

Removing incorrect milestone

comment:3 Changed 6 years ago by Steve.Organ

It has been 7 days since I logged this case, is it possible that this issue can be confirmed? Or could you let me know if there are any questions to further clarify this defect?

comment:4 Changed 5 years ago by alfonsoml

  • Status changed from new to closed
  • Priority changed from High to Normal
  • Resolution set to duplicate

There's no testcase, but the description looks like a dup of #1660

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy