Ticket #3261 (closed Bug: fixed)

Opened 6 years ago

Last modified 6 years ago

Hot Key crashes IE 7

Reported by: Senthil Owned by: fredck
Priority: High Milestone: CKEditor 3.0
Component: General Version:
Keywords: Oracle Confirmed Cc: Senthil

Description (last modified by fredck) (diff)

Hot Key crashes IE 7. Below the steps to reproduce.

Note: Assume "This is some sample text" is exist in the editor area.

  1. Select the first word "This" and press ctrl+B.
  2. Select the second word "is" and press ctrl+B twice or thrice.
  3. Now you can see the browser is being crashed.

Change History

comment:1 Changed 6 years ago by fredck

  • Description modified (diff)

comment:2 Changed 6 years ago by fredck

  • Keywords Confirmed added

Confirmed with IE7. Ok with FF.

comment:3 Changed 6 years ago by fredck

  • Owner set to fredck
  • Status changed from new to assigned

This problem happens because of the attempt of removing the "_cke_expando" attribute from inside a cloned object into the style removal procedure.

The patch provided at #3266 fixes this issue.

comment:4 Changed 6 years ago by fredck

  • Status changed from assigned to closed
  • Resolution set to fixed

I confirm this has been fixed at #3266 with [3322].

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy